Please HELP ! VERY LONG LOADINGS

    We have introduced device authorization to the forums. If you are having troubles, please shoot us a note at [email protected]

    We recently had a server update go rogue on us. This explains the slight downtime and poor performance. Please allow a hour for things to get back to normal.

    • Please HELP ! VERY LONG LOADINGS

      [sry for my bad english]
      i have 6gb of ram and my vga is 2x6870 Ati And i Have core i7 950
      but when i playing black mesa , loadings are very very long
      at first the starting loading was very long too but i add this -dxlevel 90 in the launch option and it got fixed
      but still the in game loadings are very very long , and i dont think its because of the low RAM , because it only use 20% of my ram

      what should i do ? :[

      Post was edited 1 time, last by omidelf ().

    • What do you mean exactly by very long? Is it more than 10 seconds? More than 30? A minute?

      It's not the low Ram, but one factor could be a slow RAM. What type of RAM do you have, and how is it configured (is it dual channel etc?), what's its clock speed in your PC? Also what's your CPU?

      Also, a few things that could possibly help:
      - Not running other applications in the background, or at least stopping them from scheduling tasks when you play games (e.g. antivirus/malware scans). Make sure to always close any open web browsers as well.
      - Locate any performance bottlenecks in your system and optimize them/upgrade the respective components (e.g Windows Experience Index could provide an indicator for that).
      - Having Steam installed on an SSD disc (and in Windows 7 you could also enable TRIM for better performance).
      - If not or you don't have an SSD, then at least defrag the disc where Steam is at. You could also try a RAID 0 (stripping) configuration if you got the required discs and motherboard supporting it.
    • omidelf wrote:

      [sry for my bad english]
      i have 6gb of ram and my vga is 2x6870 Ati
      but when i playing black mesa , loadings are very very long
      at first the starting loading was very long too but i add this -dxlevel 90 in the launch option and it got fixed
      but still the in game loadings are very very long , and i dont think its because of the low RAM , because it only use 20% of my ram

      what should i do ? :[


      a) What's the definition of the "very very long" for you?

      b) What is the OS you use? If it's Vista/7/8 - you shouldn't really use any other dxlevel than 98 - your GPUs are DX10+ capable. You could read more on it in the question 6 of the FAQ.

      c) Be sure not to leave -dxlevel XX swith in the game command line for longer than absolutely necessary. It is a one-time-use swith. Details - in FAQ.

      d) You could try disabling CrossFire use for BM and check if that helps.

      e) You could try adding "-preload" switch to the command line and add following to the autoexec.cfg:

      Source Code

      1. cl_forcepreload 1
      2. sv_forcepreload 1
      3. mem_max_heapsize 3000
    • ShadowNate wrote:

      What do you mean exactly by very long? Is it more than 10 seconds? More than 30? A minute?

      It's not the low Ram, but one factor could be a slow RAM. What type of RAM do you have, and how is it configured (is it dual channel etc?), what's its clock speed in your PC? Also what's your CPU?

      Also, a few things that could possibly help:
      - Not running other applications in the background, or at least stopping them from scheduling tasks when you play games (e.g. antivirus/malware scans). Make sure to always close any open web browsers as well.
      - Locate any performance bottlenecks in your system and optimize them/upgrade the respective components (e.g Windows Experience Index could provide an indicator for that).
      - Having Steam installed on an SSD disc (and in Windows 7 you could also enable TRIM for better performance).
      - If not or you don't have an SSD, then at least defrag the disc where Steam is at. You could also try a RAID 0 (stripping) configuration if you got the required discs and motherboard supporting it.


      more than 5 minute !
      and im sure my ram is not slow because i played many games like crysis 1&2 and BF3 and ... but i didn't have any problem with them

      do you think Re installing the game would help ?
    • omidelf wrote:

      more than 5 minute !
      and im sure my ram is not slow because i played many games like crysis 1&2 and BF3 and ... but i didn't have any problem with them

      do you think Re installing the game would help ?

      Oh, wow! That's really huge and something is wrong :-(.
      Yet another question just to make it clear: are you talking about the "Loading" screens that happen in-game when you travel from one level to another or is it the game in general taking that much time to simply startup?
    • lexa2 wrote:

      Oh, wow! That's really huge and something is wrong :-(.
      Yet another question just to make it clear: are you talking about the "Loading" screens that happen in-game when you travel from one level to another or is it the game in general taking that much time to simply startup?



      yep that really sucks , i played HLF2 before and the loading takes only 2-3 sec !

      and im talking about loading screens that happen in game when im traveling from one level to another

      do you think re installing the game would help ?
    • omidelf wrote:

      ... do you think re installing the game would help ?

      No, I don't think it would help but you could try in case you're out of other options.

      Could you please answer my "a-b-c-d-e" questions I posted in this thread earlier?

      As for what to do: you could try moving the game (entire Steam installation folder) to another storage if you have such an option (i.e. to another HDD or SSD if you've got one). Also you could try disabling your anti-virus and anti-spyware software prior trying to start up the game. And also you could try to add "-nosound -windowed" to the game command line parameters to check if the problems you have are related to sound-driver (there were reports about sound driver making sound precache process last for minutes).

      P.S. What's is the output in the in-game console right after you finally got the level to load? Could you please copy/paste it to this thread?
    • omidelf wrote:

      i think its something about black mesa graphic option , because i defaulted the graphic and it got fixed ! it wired , im gonna check to see why is this happening


      Nice to hear that. Please, report back if you happen to hit this problem once again and would be able to pinpoint the cause. Have a nice time playing the game!
    • lexa2 wrote:

      Nice to hear that. Please, report back if you happen to hit this problem once again and would be able to pinpoint the cause. Have a nice time playing the game!


      nope i was wrong i still have this problem ... :((((
      but wired thing is when i come back to those area that has been loaded before , loading is not long and it only take 5-6 sec , but when i enter areas that i have not been there before i takes more than 5 minute damn

      lexa2 wrote:

      a) What's the definition of the "very very long" for you?

      b) What is the OS you use? If it's Vista/7/8 - you shouldn't really use any other dxlevel than 98 - your GPUs are DX10+ capable. You could read more on it in the question 6 of the FAQ.

      c) Be sure not to leave -dxlevel XX swith in the game command line for longer than absolutely necessary. It is a one-time-use swith. Details - in FAQ.

      d) You could try disabling CrossFire use for BM and check if that helps.

      e) You could try adding "-preload" switch to the command line and add following to the autoexec.cfg:

      Source Code

      1. cl_forcepreload 1
      2. sv_forcepreload 1
      3. mem_max_heapsize 3000


      a) more than 5 minute
      b)windows 7 , 64 bit , i tried dx98 too but didn't work , i deleted everything in the launch option and still have this problem ...
      d) didn't work
      e) didn't work :((


      damn ...
    • lexa2 wrote:

      Nice to hear that. Please, report back if you happen to hit this problem once again and would be able to pinpoint the cause. Have a nice time playing the game!



      nope i was wrong i still have this stupid problem ...
      its wired because when i enter those areas that i have been before the loading only takes 4,5 sec but when i enter new areas it take more than 5 minute !!



      lexa2 wrote:

      a) What's the definition of the "very very long" for you?

      b) What is the OS you use? If it's Vista/7/8 - you shouldn't really use any other dxlevel than 98 - your GPUs are DX10+ capable. You could read more on it in the question 6 of the FAQ.

      c) Be sure not to leave -dxlevel XX swith in the game command line for longer than absolutely necessary. It is a one-time-use swith. Details - in FAQ.

      d) You could try disabling CrossFire use for BM and check if that helps.

      e) You could try adding "-preload" switch to the command line and add following to the autoexec.cfg:

      Source Code

      1. cl_forcepreload 1
      2. sv_forcepreload 1
      3. mem_max_heapsize 3000


      a)more than 5 minute

      b)seven , 64 bit , i used dx98 too but it didn't work , i deleted everything in launch option and still didn't work ...

      d)didn't work

      e)try that too but didn't work :(((((



      what should i do ? :(

      p.s : i have core i7 950

      Post was edited 1 time, last by omidelf ().

    • omidelf wrote:

      nope i was wrong i still have this stupid problem ...
      its wired because when i enter those areas that i have been before the loading only takes 4,5 sec but when i enter new areas it take more than 5 minute !!


      This is almost certainly a caching problem of some kind. lexa2 previously suggested that you try running the game with "-nosound" in the launch options - have you tried that?
    • geekofalltrades wrote:

      You might need to enable the console in the "Advanced" section of the Keyboard tab in the settings menu. This isn't something you do in the console, though. Right click on Black Mesa in your games list, bring up properties, and add "-nosound" to the end of the properties line. Then launch Black Mesa and see if that fixes the loading problem.


      i try that too but it didn't work ...
    • your ` key is probably in another language, make sure your keyboard is set to English

      To have it permanently on, put -console in launch options, to find it, right click BM on your game list and press properties.

      Sersoft : You just haven't spent enough time on the internet to understand.
      Someonerandm : Understand what?
      Ramirezoid : exactly.