Compile Tools - Differences Between Engine Versions?

    Logging in with you Steam ID has now been restored ♥

    • Compile Tools - Differences Between Engine Versions?

      There's got to be a better title for this thread than that... Oh well.

      Backstory: I'm a huge nerd when it comes to game development. Prototypes and the like are massively interesting to me, even if they crash a lot. As a result, I've got both the leaked 2003 HL2 binaries and the older "WC Map pack" on this computer (THERE IS NO DISTRIBUTION GOING ON IN THIS THREAD - I'm assuming that since discussion is okay, this thread is fine too, I apologize if that's not the case). Out of boredom/curiosity, I've tried fixing up a few of the leaked maps to run in-game (more specifically, Synergy, for one of my friends and I to mess about in) with varying levels of success (Since a lot of these maps are from, like, 2001/2002, they work quite differently entity-wise to the "final" engine). I was working on fixing up one map when I ran into... Something kind of strange.

      For starters, the map has no leaks. The compile log and lack of a pointfile agree with me on this. There are a bunch of lights scattered throughout the map, too. The thing is, when I compile the map to run in Synergy, it comes out fullbright under a full compile (VRAD/VVIS included). I tried fiddling with it for a while to see if I could fix it, no dice.

      On a whim, though, I tried compiling it via the L4D1 Authoring Tools. I didn't bother fixing up any of the problems like missing models or obsolete entities in doing so, it was just for a laugh. What confused me, though, is that it came out properly lit in L4D1. While I know the compile tools are going to get updated alongside the engine branch, I don't understand how L4D's build tools can light the level properly, while Synergy's (Which are the same as the 2013 Source SDK, IIRC) can't.

      Basically: Does anyone know why the different compile tools would be giving off different results like this? I'm not overly concerned with "fixing" it, since this was just a side project type of thing, but I'm confused as to what the deal is here.
    • Tried that, no dice.

      Having said that, I did manage to get it working - I selected all the lights and moved them down a few units (I think 2 or 3 of them were clipping into models), and deleted a bunch of extraneous light_environment entities... And suddenly it's lit up properly in Synergy.

      I'm not entirely sure which of those two made the difference, but... Mystery kind of solved?