Pinned How to report an issue

    Logging in with you Steam ID has now been restored ♥

    • Some major map glitches or rendering issues or who knows what abomination.
      I tried setting it to both GeForce (GTX 980M) and integrated graphics, same results.

      Here is my whole console:

      CampaignManager: Campaign file "campaigns/campaign_bm_sp.txt" is malformed, failed to parse.
      Steam config directory: D:\Games\steamapps\common\Black Mesa\platform\config
      CClientSteamContext logged on = 1
      Parent cvar in client.dll not allowed (r_eyegloss)
      For FCVAR_REPLICATED, ConVar must be defined in client and game .dlls (mp_warmup_intermission_time)
      For FCVAR_REPLICATED, ConVar must be defined in client and game .dlls (mp_warmup_time)
      For FCVAR_REPLICATED, ConVar must be defined in client and game .dlls (mp_round_intermission_time)
      Parent cvar in server.dll not allowed (bm_multiplayer_persistent_scores)
      For FCVAR_REPLICATED, ConVar must be defined in client and game .dlls (bm_multiplayer_fall_protection)
      Hud element 'CHudBootUpSequence' doesn't have an entry 'CHudBootUpSequence' in scripts/HudLayout.res
      Init MultiPlayer Params
      Init MultiPlayer Params
      Initializing brass ejection system.
      Parsing ejection information for weapon_glock.
      Parsing effect glock-primary-attack.
      Parsing effect glock-primary-attack-thirdperson.
      Parsing ejection information for weapon_mp5.
      Parsing effect mp5-primary-attack.
      Parsing effect mp5-primary-attack-thirdperson.
      Parsing ejection information for weapon_shotgun.
      Parsing effect shotgun-primary-attack.
      Parsing effect shotgun-primary-attack-thirdperson.
      Parsing effect shotgun-secondary-attack.
      CampaignManager: Campaign file "campaigns/campaign_bm_sp.txt" is malformed, failed to parse.
      Unknown command "mat_spewalloc"
      Unknown command "mat_spewalloc"
      'userconfig.cfg' not present; not executing.
      --- Missing Vgui material vgui/servers/icon_replay
      --- Missing Vgui material vgui/servers/icon_replay_column
      Unknown command "sk_plr_crossbow_speed"
      Init SinglePlayer Params
      Init SinglePlayer Params
      Queue complete.
      Requesting texture value from var "$basetexture" which is not a texture value (material: skybox/bm_sky_underground_00rt)
      Requesting texture value from var "$basetexture" which is not a texture value (material: skybox/bm_sky_underground_00bk)
      Requesting texture value from var "$basetexture" which is not a texture value (material: skybox/bm_sky_underground_00lf)
      Requesting texture value from var "$basetexture" which is not a texture value (material: skybox/bm_sky_underground_00ft)
      Requesting texture value from var "$basetexture" which is not a texture value (material: skybox/bm_sky_underground_00up)
      Requesting texture value from var "$basetexture" which is not a texture value (material: skybox/bm_sky_underground_00dn)
      Failed to load sound "vo\c3a1a\forgetaboutfreeman\radio_faf01_radiosilence.wav", file probably missing from disk/repository
      Init SinglePlayer Params
      Init SinglePlayer Params
      Compact freed 634880 bytes
      JOY_AXIS_X: mapped to Turn (absolute)
      JOY_AXIS_Y: mapped to Look (absolute)
      JOY_AXIS_Z: unmapped
      JOY_AXIS_R: mapped to Forward (absolute)
      JOY_AXIS_U: mapped to Side (absolute)
      JOY_AXIS_V: unmapped
      Advanced Joystick settings initialized
      Dropped ttsoyale from server (Server shutting down)
      maxplayers set to 1
      Unknown command "mat_spewalloc"
      Loading game from save\bms-003.sav...
      Loading game from //MOD/save/bm_c2a2a.HL1...
      Unknown command "sk_plr_crossbow_speed"
      2 GodRaysEffect ??ERROR: path_track (pathTram_a96) refers to itself as a target!
      Dead end link: c2a2b_tram_stop_41
      Compact freed 1302528 bytes
      ] status
      hostname: Black Mesa
      version : 100003/24 100003 insecure
      map : bm_c2a2a at: 2102 x, 271 y, 625 z
      # userid name uniqueid connected ping loss state adr
      tags :
      players : 1 humans, 0 bots (1 max)
      # 3 "ttsoyale" STEAM_ID_PENDING 03:08 16 0 active loopback
      edicts : 923 used of 2048 max
      ] getpos
      setpos 2102.701904 271.336212 625.948486;setang -9.209764 -49.492016 0.000000
      Files
    • One thing I noticed going through the beta of STU (started a new game at Residue Processing) is that in the first room of RP (the trash compactor) the security camera is using the wrong animation for the direction it should be facing - it's looking right, towards the control booth, when the screen on the monitor inside the control booth clearly indicates it should be using the left animation of the same angle, facing towards the compactor.

      The Javid wrote:

      I can't wait til we ditch that pattern too. It only blends in with gravel and shitty couches.
    • In the public beta, after I finished everything in coolant chamber 01, the AI was disabled in bm_c3a2c. I went back to bm_c3a2e and it was fine there, but it's disabled again when I go to bm_c3a2c.
      20160514094701_1.jpg

      Update: bm_c3a2c is still the same after finishing coolant chamber 02
      20160514102607_1.jpg

      Update: AI is enabled again in bm_c3a2f, until the vortigaunts spawn. The "AI Disabled" message on the hud disappears once they're all dead, and reappears when more spawn.
      20160514103527_1.jpg20160514103824_1.jpg20160514103827_1.jpg

      Update: This continued through the rest of the chapter. When I restarted the game and loaded bm_c3a2f through the console, there was no problem.

      The post was edited 6 times, last by SirEgon: Learned more about the bug ().

    • Really low-priority issue, but I found a couple minor things with props_industrial/light_strip03_nowire.mdl - It wasn't compiled with allowstatic, Presumably because it's never needed to be used as a static prop, and also because it's fairly easy to work around by just using a prop_dynamic instead unless your map is on the razor's edge of entdata. The other thing is that the model's skins aren't quite set up properly - the fixture material changes the same way the other light_strip03 models do, but the bulb doesn't, leaving it dark even when the light is "on".

      20160720120613_1.jpg

      It's not really a massive issue, but for the few situations where a level designer might want to place one of those fixtures flush with a wall or ceiling and doesn't have room for the wires to stick out the other side, it leaves things looking a bit off.

      The Javid wrote:

      I can't wait til we ditch that pattern too. It only blends in with gravel and shitty couches.
    • Map: every map

      For some reason a lot of non-physics objects are solid black. Does anyone else have this issue, and more importantly, does anyone know how to fix it? I've tried changing my graphics settings, and I've tried reinstalling Black Mesa, but neither work.

      EDIT: nvm it somehow fixed itself
      Files

      The post was edited 2 times, last by CroakerFrog ().

    • Map: bm_c1a1b
      Setpos: setpos 695.584900 1229.948853 576.031250;

      The vent you crawl through here can be accessed again once you leave it by climbing onto the desk next to it and jumping in, this is a problem the game is scripted to delete the security guard you escort to the lobby and all the fires in that area, so if you go back it bugs out.
    • another bug:
      Map: c1a1b
      Getpos: setpos -415.150513 1234.031250 544.031250;

      if you shoot where the crosshair is in the screenshot, it breaks the scripted sequence and teleports the chair, scientist, and headcrabs into that spot, and they just kinda sit there, as you can see in the screenshot.
      Files