Black Mesa Patch - 0.2.1 - Jan 24th, 2016

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    Logging in with you Steam ID has now been restored ♥

    • Black Mesa Patch - 0.2.1 - Jan 24th, 2016

      We've released a patch to Black Mesa main client

      • Fixed bouncing Bolts from the crossbow in MP
      • Fixed a bug in the balanced spawn system
      • Fixed Shotgun Collision model
      • Fixed various spelling errors and missing .wav files in dialouges.
      • Fixed the Crossbows lighting origin
      • RPG rocket won't clip with the rocket when reloading.
      • Dr. Kleiners head and hands are now properly smooth (smoooooth as jazz)
      • Fixed blood not splattering on the MP5
      • Fixed the where placing 11 satchels crashed the MP server
      • Crossfire Optimization increased - will run much smoother now.
      • Added muzzle flash dynamic light checkbox to options menu.
      • Added godrays enable checkbox to the options menu
      • Minor optimizations made to netcode.
      • Fixed 'FIX IT DENIZ' skin on monitor in UC.
      • Fixed game_round_win Entity to actually win rounds.
      • Polished the workshop tool. (like, it works now, and you can upload thumbnails)
        • All workshop content and addons will now be found/located in the SteamApps/Workshop/Content/362890 folder
      This update may corrupt and break save files. If you're experience any issues with old loads, please restart the game at the start of that chapter. You can do that by clicking "New Game" on the main menu, and picking the latest chapter you were on.

      Additionally, if you are experiencing issues with missing models or textures in-game, you have a legacy error with mods. If you have subscribed to any mods since launch and are experiencing these issues please do the following steps to fix the issue.
      1. Unsubscribe from all Black Mesa mods
      2. Go to ***\SteamApps\workshop\content\362890 (where *** is the location to where your steam games may be)
      3. Delete all folders within this folder
      4. Launch Black Mesa, and you should be good to go.
      Once you do this, you should be able to re-subscribe to any and all mods that you want.

      Not sure which mods to download? Why not try On a Rail Uncut - now officially released on the Steam Workshop.

      EDIT:
      It is known that the Workshop Addon's button doesn't work in the Main Menu (whoops!)
      The Snark King. Ruler of all Snarks.

      The post was edited 2 times, last by Fr0z3n ().

    • Fr0z3n wrote:

      Could you elaborate a bit more? Where are you placing the .vpks?
      VPK files in bms\addons folders are not being recognized anymore by the game (issue that had existed since the first Public Beta release). Where do we put our VPKs now?

      Also, could you tell us which console command control the godrays (enable/disable)? I need it for... a reason.
      "... Some people say, "How can you live without knowing?" I do not know what they mean. I always live without knowing. That is easy. How you get to know is what I want to know."
      - Richard Feynman, The Meaning of It All

      steamcommunity.com/id/KevinJRattman/
    • Fr0z3n wrote:

      Dalek wrote:

      Its also not loading non workshop vpks
      Could you elaborate a bit more? Where are you placing the .vpks?

      KevinJRattman wrote:

      Fr0z3n wrote:

      Could you elaborate a bit more? Where are you placing the .vpks?
      VPK files in bms\addons folders are not being recognized anymore by the game (issue that had existed since the first Public Beta release). Where do we put our VPKs now?
      Also, could you tell us which console command control the godrays (enable/disable)? I need it for... a reason.
      Same problem with the vpks here
    • KevinJRattman wrote:

      Fr0z3n wrote:

      Could you elaborate a bit more? Where are you placing the .vpks?
      VPK files in bms\addons folders are not being recognized anymore by the game (issue that had existed since the first Public Beta release). Where do we put our VPKs now?
      Also, could you tell us which console command control the godrays (enable/disable)? I need it for... a reason.

      Dalek wrote:

      Fr0z3n wrote:

      Dalek wrote:

      Its also not loading non workshop vpks
      Could you elaborate a bit more? Where are you placing the .vpks?

      KevinJRattman wrote:

      Fr0z3n wrote:

      Could you elaborate a bit more? Where are you placing the .vpks?
      VPK files in bms\addons folders are not being recognized anymore by the game (issue that had existed since the first Public Beta release). Where do we put our VPKs now?Also, could you tell us which console command control the godrays (enable/disable)? I need it for... a reason.
      Same problem with the vpks here
      That is because the bms/addons folder is now obsolete. .vpk'd workshop content is being looked for in SteamApps/Workshop/Content/362890 in folders with their associated Workshop ID's.

      I will adjust the notes to reflect this change. Sorry for the confusion.
      The Snark King. Ruler of all Snarks.
    • Fr0z3n wrote:

      That is because the bms/addons folder is now obsolete. .vpk'd workshop content is being looked for in SteamApps/Workshop/Content/362890 in folders with their associated Workshop ID's.

      I will adjust the notes to reflect this change. Sorry for the confusion.
      It's a problem about non-workshop VPKs, not workshop contents. I tried to put VPKs in content\362890 but it doesn't work... Also, please help me with the command for godrays?
      "... Some people say, "How can you live without knowing?" I do not know what they mean. I always live without knowing. That is easy. How you get to know is what I want to know."
      - Richard Feynman, The Meaning of It All

      steamcommunity.com/id/KevinJRattman/
    • So I've run a couple tests, does the Workshop tool just have trouble with some weird class of addon?
      I was able to successfully upload a small test VPK (15MB of materials) and everything seemed to go alright, but for after trying two separate actual addons (materials & models) it doesn't seem to really complete. It gives me the "User Content Successfully Uploaded!" message, but upload completion bar locks at 50%, and the Workshop entry is borked.

      Since no one else seems to be having issues, including Text when he uploaded OaRU recently, I'm assuming it's some strange clientside issue I'm having that's persisted passed reinstalls/branch switches, in which case I'll probably just stop submitting to the Workshop as it's not really worth the additional hassle. Holy run-on sentence.

      On the other hand, kickass that we've got some good bugfixes, I do enjoy my shotguns colliding properly and my Kleiners smooth. :thumbsup:
      And so ends another post of pointless speculation.

      "120% sorry!"
    • Crypt wrote:

      So I've run a couple tests, does the Workshop tool just have trouble with some weird class of addon?
      I was able to successfully upload a small test VPK (15MB of materials) and everything seemed to go alright, but for after trying two separate actual addons (materials & models) it doesn't seem to really complete. It gives me the "User Content Successfully Uploaded!" message, but upload completion bar locks at 50%, and the Workshop entry is borked.

      Since no one else seems to be having issues, including Text when he uploaded OaRU recently, I'm assuming it's some strange clientside issue I'm having that's persisted passed reinstalls/branch switches, in which case I'll probably just stop submitting to the Workshop as it's not really worth the additional hassle. Holy run-on sentence.

      On the other hand, kickass that we've got some good bugfixes, I do enjoy my shotguns colliding properly and my Kleiners smooth. :thumbsup:

      Actually, Chon was having an issue with it making a blank workshop file and that was because he was trying to upload a thumbnail that was 1920x1080 (silly Chon). I would recommend 512x512 or lower if you're doing thumbnails. Give that a try, and let me know. We did do some work to .vpk stuff... though it's unrelated to the workshop, it is programming so who knows.

      Dalek wrote:

      So then how do we load non workshop VPKs?

      KevinJRattman wrote:

      Fr0z3n wrote:

      That is because the bms/addons folder is now obsolete. .vpk'd workshop content is being looked for in SteamApps/Workshop/Content/362890 in folders with their associated Workshop ID's.

      I will adjust the notes to reflect this change. Sorry for the confusion.
      It's a problem about non-workshop VPKs, not workshop contents. I tried to put VPKs in content\362890 but it doesn't work... Also, please help me with the command for godrays?
      No, putting them in the folder alone won't work, they will need a folder with their workshop ID in it to work.
      I don't actually know if we can do non-workshop vpk's anymore. Obvious workaround is to upload whatever you want as a workshop item, but keep it hidden so only you can subscribe to it/see, then it'll work.

      Godray console command: bms_gr_enabled 0/1 (0 is off, 1 is on)

      I'll check back tomorrow with info on non-workshop .vpk's.
      The Snark King. Ruler of all Snarks.
    • Fr0z3n wrote:

      No, putting them in the folder alone won't work, they will need a folder with their workshop ID in it to work.
      I don't actually know if we can do non-workshop vpk's anymore. Obvious workaround is to upload whatever you want as a workshop item, but keep it hidden so only you can subscribe to it/see, then it'll work.

      Godray console command: bms_gr_enabled 0/1 (0 is off, 1 is on)

      I'll check back tomorrow with info on non-workshop .vpk's.


      Thanks so much for reply. I really hope you consider re-add support for non-workshop vpks as it's very inconvenient to re-upload my work to worshop everytime just for testing purposes. I know you can just use bms folder, but it gets cluttered really fast and I really appreciate sorting my works (I have lots of them) folder by folder, vpk by vpk.
      "... Some people say, "How can you live without knowing?" I do not know what they mean. I always live without knowing. That is easy. How you get to know is what I want to know."
      - Richard Feynman, The Meaning of It All

      steamcommunity.com/id/KevinJRattman/
    • KevinJRattman wrote:

      Fr0z3n wrote:

      No, putting them in the folder alone won't work, they will need a folder with their workshop ID in it to work.
      I don't actually know if we can do non-workshop vpk's anymore. Obvious workaround is to upload whatever you want as a workshop item, but keep it hidden so only you can subscribe to it/see, then it'll work.

      Godray console command: bms_gr_enabled 0/1 (0 is off, 1 is on)

      I'll check back tomorrow with info on non-workshop .vpk's.
      Thanks so much for reply. I really hope you consider re-add support for non-workshop vpks as it's very inconvenient to re-upload my work to worshop everytime just for testing purposes. I know you can just use bms folder, but it gets cluttered really fast and I really appreciate sorting my works (I have lots of them) folder by folder, vpk by vpk.
      Mmm, thats not something I really considered. The alternative is to just do proper file replacement/conversions. I'll let you know.
      The Snark King. Ruler of all Snarks.
    • Fr0z3n wrote:

      I would recommend 512x512 or lower if you're doing thumbnails. Give that a try, and let me know.

      Well, I'll be damned, that did the trick!

      Anyway, I'll wait on that non-workshop VPK info. While that feature wouldn't be a horrible loss, I've been abusing the hell out of it for dev stuff.
      And so ends another post of pointless speculation.

      "120% sorry!"
    • RageMaker wrote:

      Is it still viable to put mods in the custom folder?

      Also, I'm still having problems with the workshop mods. So I subscribe, move the folders so that other one, then un sub?
      I just tried this: Yes, it works! At least, on my end, that is. This should be a much better workaround than to upload every time I make edits on my (unreleased) mods...
      "... Some people say, "How can you live without knowing?" I do not know what they mean. I always live without knowing. That is easy. How you get to know is what I want to know."
      - Richard Feynman, The Meaning of It All

      steamcommunity.com/id/KevinJRattman/
    • addons containing the sound still does not work after entering the console "snd_restart" sound starts, but after entering the game again there is no sound, not tested on raspakovanom modes, but if you use a replacement sound "vpk", this error occurs.

      The post was edited 1 time, last by haos9cr ().