Music not playing.

    • Music not playing.

      Hi all,

      Every time I start the game none of the music tracks play. I've checked the console and I get this type of error message:

      Attempting to play MP3 with no vaudio [ ui\gamestartup_1.ogg ]
      Failed to create decoder for MP3 [ ui\gamestartup_1.ogg ]

      I've tried deleting and reinstalling, turning off Steam Cloud, verifying game cache files, deleting all mods, and deleting remotecahce.vdf, deleting soundcache, and snd_restart.
      But nothing seems to be working

      Any help would be greatly appreciated!
    • I'm having this issue as well - fired up Black Mesa for the first time in a while, started a new game, and was surprised to not hear any music. Ambient audio and other sounds are present.

      Seeing the same thing in the console as Rancho:


      Source Code

      1. music\bms - inbounda.ogg ]
      2. Attempting to play MP3 with no vaudio [ music\bms - inbounda.ogg ]
      3. Failed to create decoder for MP3 [ music\bms - inbounda.ogg ]
      No mods, vanilla install.
    • Posting in multiple places in the same forum is not recommended.

      Trouble shooting something like this has to be done in a certain order. You may have done all the steps, but if they were not done in the correct order you will continue to have no music.

      Do all of this in the following order. Skipping a step or doing them out of order nullifies the process.

      1. Restart your computer.

      2. Exit Steam.

      3. Next, I would unsubscribe from any mods in the workshop.
      Then completely remove them using this method:
      • Unsubscribe from all Black Mesa mods
      • Go to ***\SteamApps\workshop\content\362890 (where *** is the location to where your steam games may be)
      • Delete all folders within this folder


      4. Delete all sound.cache files in your /bms/sound directory. (CPU's recommendation)

      5. Start Steam.

      6. Verify the integrity of your Game Cache. Right click Black Mesa, Click Properties, then click "Verify Integrity of Game files." Let it do its thing, and download anything missing/corrupted.
    • CPU wrote:

      Try this again.


      Close down Steam.
      Then, make sure you delete the sound.cache located in Steam/steamapps/common/Black Mesa/bms/sound.

      Then, restart Black Mesa and in the console type snd_restart.

      RedEye wrote:

      Posting in multiple places in the same forum is not recommended.

      Trouble shooting something like this has to be done in a certain order. You may have done all the steps, but if they were not done in the correct order you will continue to have no music.

      Do all of this in the following order. Skipping a step or doing them out of order nullifies the process.

      1. Restart your computer.

      2. Exit Steam.

      3. Next, I would unsubscribe from any mods in the workshop.
      Then completely remove them using this method:
      • Unsubscribe from all Black Mesa mods
      • Go to ***\SteamApps\workshop\content\362890 (where *** is the location to where your steam games may be)
      • Delete all folders within this folder


      4. Delete all sound.cache files in your /bms/sound directory. (CPU's recommendation)

      5. Start Steam.

      6. Verify the integrity of your Game Cache. Right click Black Mesa, Click Properties, then click "Verify Integrity of Game files." Let it do its thing, and download anything missing/corrupted.
      Neither of these methods worked.
    • Alright so, after trying every fix I could find I think I might have found a solution.

      (Although I'm not sure if it was due to this, specifically. It could quite possibly have been some other fix. I recommend trying everything else suggested before this.)

      I'm posting it here in case anyone else with this same issue wants to give it a try, however note that this involves deleting your stored Steam Cloud data:





      The instructions are little complicated and involves precise, nerdy wizardry, but after I was able to reset my Steam Cloud data for Black Mesa back to 0 MBs, the original Black Mesa soundtrack was apparently restored.

      Give a shot and good luck!
    • This still didn't work for me - PowerShell is giving me "PermissionDenied" errors even though I run it as administrator, and I can never get the Sync Conflict message to appear by Black Mesa using the second method in that forum post.

      I've even uninstalled and reinstalled Black Mesa, being careful to delete both the remotecache.vdf and sound.cache files in between, with no change. Same console messages.
    • Try this PowerShell command. It will update the timestamp of the config.cfg file, which should (I hope) trigger a Sync Conflict:

      Source Code

      1. (dir 'C:\Program Files (x86)\Steam\userdata\[SteamID]\362890\remote\cfg\config.cfg').LastWriteTime = get-date
      Note: Replace "[SteamID]" with the correct folder name on your computer (a number connected to your Steam Account ID). Also, replace "C:\Program Files (x86)" with the correct folder if Steam has been installed in a different folder.

      Then start the Steam client and launch Black Mesa. If the Sync Conflict dialog comes up, before you do anything, delete the following files:
      1. Everything in the "C:\Program Files (x86)\Steam\userdata\[SteamID]\362890 folder ("remotecache.vdf" and the "remote" folder).
      2. All sound.cache files.
      3. Everything in the "***\steamapps\workshop\content\362890" folder (after unsubscribing to any mods).
      4. "***\steamapps\common\Black Mesa\bms\cfg\config.cfg"
      5. All the savegames in the "***\steamapps\common\Black Mesa\bms\save" folder (you may want to back them up first).
      Then go back to the Sync Conflict dialog and click "Upload to the Steam Cloud".
    • shadedmagus wrote:

      @Flavrans
      I tried your steps, but never saw a Sync Conflict message.
      I've used the timestamp trick successfully when I needed to restore an older config.cfg. But the file would have been different than the one in the cloud, so it's possible the file needs to be changed as well as have a more recent timestamp. If so, clearing the file should do it:

      Source Code

      1. clc 'C:\Program Files (x86)\Steam\userdata\[SteamID]\362890\remote\cfg\config.cfg'
      (Again, replace "[SteamID]" with the appropriate folder. Also make sure you include the single quotes around the file path.)

      You could also just open the "config.cfg" file in Notepad, edit it or clear out all its contents, and save.

      shadedmagus wrote:

      Could I open a ticket with Steam and get them to delete the Steam Cloud files? Not sure if that's something they would do.
      I can't really say, but if the problem is caused by some corrupt or incorrect data in the Steam Cloud, then you should in theory be able to fix it by disabling the Steam Cloud synchronization for Black Mesa:

      Right click on Black Mesa in the Steam Library and click Properties. Then select the Updates tab and uncheck the "Enable Steam Cloud synchronization for Black Mesa". Restart Steam.

      Then try the other suggestions again. (Alternatively, completely uninstall Black Mesa, delete any leftover files/folders in "***\steamapps\common\Black Mesa" and reinstall. Then verify the cache once.)

      One of the suggestions was to delete sound.cache from the "Black Mesa\bms\sound" folder, but for good measure make sure you delete all the *.cache files in the "Black Mesa\bms", "Black Mesa\bms\sound", "Black Mesa\hl2" and "Black Mesa\hl2\sound" folders. Also delete "config.cfg" (and userconfig.cfg if it exists) in the "Black Mesa\bms\cfg" folder, and the savegames in "***\steamapps\common\Black Mesa\bms\save".

      Another thing you could try is to launch the game once with the -autoconfig launch option.

      If disabling Steam Cloud synchronization and cleaning up / reinstalling Black Mesa doesn't resolve the problem, then there must be something else going on, and I'm not sure what else to suggest.

      The post was edited 1 time, last by Flavrans ().

    • I am also having the same problem and I've tried all of the steps listed. Maybe FAMGUY made an error in the update which removed the music.

      And I am having the same problems:

      Attempting to play MP3 with no vaudio [ ui\gamestartup_2.ogg ]
      Failed to create decoder for MP3 [ ui\gamestartup_2.ogg ]

      does that mean there is a bad connection between the game and the audio files?

      The post was edited 3 times, last by Demolitionist1 ().

    • Same thing. Just bought the game and no music at all. It just keeps going:



      Attempting to play MP3 with no vaudio [ ui\gamestartup_1.ogg ]
      Failed to create decoder for MP3 [ ui\gamestartup_1.ogg ]
      Attempting to play MP3 with no vaudio [ ui\gamestartup_1.ogg ]
      Failed to create decoder for MP3 [ ui\gamestartup_1.ogg ]
      Attempting to play MP3 with no vaudio [ ui\gamestartup_1.ogg ]
      Failed to create decoder for MP3 [ ui\gamestartup_1.ogg ]
      Attempting to play MP3 with no vaudio [ ui\gamestartup_1.ogg ]
      Failed to create decoder for MP3 [ ui\gamestartup_1.ogg ]
      Attempting to play MP3 with no vaudio [ ui\gamestartup_1.ogg ]
      Failed to create decoder for MP3 [ ui\gamestartup_1.ogg ]
      Attempting to play MP3 with no vaudio [ ui\gamestartup_1.ogg ]
      Failed to create decoder for MP3 [ ui\gamestartup_1.ogg ]
      Attempting to play MP3 with no vaudio [ ui\gamestartup_1.ogg ]
      Failed to create decoder for MP3 [ ui\gamestartup_1.ogg ]
      Attempting to play MP3 with no vaudio [ ui\gamestartup_1.ogg ]
      Failed to create decoder for MP3 [ ui\gamestartup_1.ogg ]

      over and over andover and over andover and over andover and over and over and over andover and over andover and over andover and over andover and over andover and over and over and over andover and over andover and over andover and over
    • Well, I thought this might have been fixed - I just reinstalled Black Mesa today, and when I started it up I heard music on the main menu screen!

      However, when I started a new game, I heard no music for Inbound, and saw the same console messages as before.

      Source Code

      1. Failed to create decoder for MP3 [ music/bms - inbounda.ogg ]



      After that, when I went back to the main menu, there was no more music. Closing and restarting Black Mesa had no effect.

      The post was edited 1 time, last by shadedmagus ().

    • The ogg decoder .dlls in the "Black Mesa\bin" directory (libogg.dll and libvorbis.dll) are dependent on the Microsoft Visual C++ 2010 Redistributable Package (x86). If it's not installed on your system you'll need to download and install it. Installing it seems to resolve the issue for some users.

      The most recent version of the Visual C++ 2010 Redistributable Package is available here: Microsoft Visual C++ 2010 Service Pack 1 Redistributable Package MFC Security Update

      Only the Microsoft Visual C++ 2013 Redistributable Packages have been bundled with the game.

      EDIT:

      These are several versions of the VC++ 2010 redistributables available for download:

      Microsoft Visual C++ 2010 Redistributable Package (x86)
      Microsoft Visual C++ 2010 Redistributable Package (x64)
      Microsoft Visual C++ 2010 RTM Redistributable MFC Security Update
      Microsoft Visual C++ 2010 SP1 Redistributable Package (x86)
      Microsoft Visual C++ 2010 SP1 Redistributable Package (x64)
      Microsoft Visual C++ 2010 Service Pack 1 Redistributable Package MFC Security Update

      Ideally, one should install the same version the developer used when the program/.dll files were built.

      The version I seem to have installed on my system (which apparently works since I have music) should be the same version installed by the package found in the last link.

      If "Give me updates for other Microsoft products when I update Windows." is enabled in your Windows Update settings, you'll receive updates for the Visual C++ redistributables as well, which might be a good idea.

      I have both the x86 (32-bit) and the x64 (64-bit) version installed, but you'll only need to install the 32-bit version, since libogg.dll and libvorbis.dll are 32-bit .dll's.

      The post was edited 4 times, last by Flavrans: Additional info. ().

    • This did not work either - turned out I already had the 2010 Visual C++ Redistributable installed. I downloaded the link you specified (last one in the list, that works for you), and it gave me the option to repair. So I did.

      I noticed while doing this and then troubleshooting subsequently that when I delete all the sound .cache files from the /hl2 folder and then restart the game, I hear music on the main menu the first time it loads up. But when I start a new game, no music - and when I go back to the main menu, no music until I delete the .cache files again.

      Hope this helps in troubleshooting.
    • Dead thread. I know. But I found a solution (that worked for me and will more than likely work for you) for this issue, and it's installing the "Microsoft Visual C++ 2010 Redistributable Package (x86)" from Microsoft's website (microsoft.com/en-ca/download/confirmation.aspx?id=5555). Restart Steam just to be sure.

      Hope this helps anyone who stumbles across this thread in the future who is having the same problem. I posted this simply because I hate unsolved threads that are over a year old...
      Thank you for helping us help you help us all.