Invisible Materials in BM2015 Hammer

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Invisible Materials in BM2015 Hammer

      Wow, it's been a while since I've been here. Er, hi! ^^; Anyways.

      Back in March of last year, I showed off a few screenshots of an OaR mod that I was working on as a way to familiarize myself with single-player Source mapping. While I did get the blockouts of the new areas all finished, I didn't do a particularly good job of keeping things clean in Hammer. On top of that, with the second map, I'm pretty sure I basically just retextured parts of the blockout and called it a day, resulting in a very boring looking level in some areas.

      Since then, I've definitely learned a lot about using Hammer effectively, mostly via mucking around (and in a few cases, re-creating) with some of the early leaked HL2 maps. I don't recall exactly what prompted it, but I ended up taking another look at my OaR mod, and ended up getting inspired to work on it again. Having said that, between the fact that I was much less skilled/disciplined at the time (I've since started using visgroups almost religiously, for example) and the fact that it had been literally months since I'd touched the .vmf's, I figured the best approach would be to start from the very beginning and do things properly. Plan the layout in advance, block it out, make sure it plays well, etc.

      To that end, though, I've run into a... very strange issue with BM 2015's Hammer - namely, many of the materials simply don't render in the 3D view. At first, I thought the .vmf was corrupted somehow and a bunch of the geometry was lost, but nope, a handful of textures simply do not appear, even when the brushes are selected. A screenshot to demonstrate, from bm_c1a2c:



      This is the first time I've ever seen anything like this, and I've got no idea how to fix it. I've tried completely reinstalling BM (i.e. deleting the entire common/Black Mesa directory) as well as verifying the game cache, but the problem persists. As you can probably guess, navigating the 3D view like this is nigh-on impossible.

      This isn't a case of the "Render Nodraw" option being unchecked - this occurs both with and without it active, and it's happening to more than just nodraw faces, anyways. Of the Hammer versions I've used recently (HL2EP2, GMod, L4D, and BM), only Black Mesa's has this problem.

      Anyone have any idea how to go about fixing this? Thanks. ^^
    • The shaded view doesn't work properly, make sure it's just set to textured rather than textured shaded. Alternatively, this problem can happen (and it has happened to me) because you're using a laptop and Hammer is trying to use your integrated video chip rather than your graphics card. If that's happening, you need to use your GPU control panel to force Hammer to use the GPU.

      The Xen update will bring with it a lot of nice little Hammer updates. The shaded view will work properly on the Xen branch.
      Chon Kemp - Level Designer and Community Manager
      Creator of the Black Mesa "Uncut" Mods - Surface Tension Uncut and
      On a Rail Uncut
      My dev blog on the development of dm_gasworks