i, too, am experiencing the issue where Black Mesa doesn't launch

    • Bug
    • Global

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • i, too, am experiencing the issue where Black Mesa doesn't launch

      This issue has existed ever since I bought and installed the retail version of Black Mesa.
      It'll say "preparing to launch", Black Mesa will show "Running" for a few seconds and my Steam icon's border will turn green, and bms.exe will appear in task manager for a few moments, but then it just quietly exits and my icon turns blue again.

      There's no dump in Steam\dumps\, but here's what shows up in Event Viewer when I try to run the game:
      Faulting application name: bms.exe, version: 0.0.0.0, time stamp: 0x59833c8f
      Faulting module name: vstdlib.dll, version: 0.0.0.0, time stamp: 0x59833c5a
      Exception code: 0xc0000005
      Fault offset: 0x00004a1e
      Faulting process id: 0x3bd0
      Faulting application start time: 0x01d34066a1c35b07
      Faulting application path: F:\Steam\steamapps\common\Black Mesa\bms.exe
      Faulting module path: F:\Steam\steamapps\common\Black Mesa\bin\vstdlib.dll
      Report Id: bb4fb75b-8d68-49b5-a95a-653ef8f79c3b
      Faulting package full name:
      Faulting package-relative application ID:

      i'm running:
      Windows 10 Home (x64) v1703 build 15063.608
      12GB RAM
      AMD Radeon RX 580 (Software Version: 17.1.1; Software Edition: Crimson ReLive)
      Intel(R) Core(TM) i5-4690K CPU @ 3.50GHz
      Gigabyte H97-HD3 motherboard

      I've tried:
      - Verifying the game cache (comes up clean)
      - Uninstalling and re-instaling the game (twice, iirc)
      - Re-installing / repairing DirectX9, VC++ 2010 and VC++ 2013 (both the x86 and x64 versions in order where possible)
      - Installing Visual C++ 2017
      - Disabling the Steam Overlay in-game (back on now), "Use Desktop Theatre while SteamVR is active", Steam Cloud synchronization (back on now)
      - Switching to each available public beta program (now back on the original)
      - Running the .exe directly, and in compatibility modes for win8 and win7, enabling "override high dpi scaling behavior", "disable fullscreen optimizations" and as admin, and also trying to run it through Steam running in admin mode
      - Expanding the file permissions for bms.exe
      - Closing Steam, removing the appmanifest file along with all the workshop-related files associated with BMS's appid (though I've never downloaded any workshop content for BMS), then restarting Steam and having it re-discover the existing files
      - Running the game off my E:\ drive rather than my main Steam directory on my F:\ drive
      - Setting launch options -windowed -noborder
      - Setting launch option -condebug
      - Setting launch option -autoconfig
      - Making absolutely sure I don't still have the sourcemod version installed somewhere
      - Removing vstdlib.dll; replacing it with a renamed vstdlib_s.dll, replacing it with the vstdlib.dll found in HL2's directory, then eventually putting the original back
      - Disabling the WattMan profile automatically generated by my AMD Radeon software
      - Restarting the computer (also several times, between steps and also this is the most recent thing I've done)

      I miss being able to play this game

      The post was edited 1 time, last by towai ().