Resolution scaling issue from the steam forums

    • Bug
    • Global
    • Resolution scaling issue from the steam forums


      [ANSWERED]
      Wrong resolution in windowed mode

      keggerius wrote:

      I am using the launch options -windowed -w -h. This works perfectly for other Source games, but Black Mesa thinks my 3840x2160 monitor is 2560x1440 for some reason, so it scales the window up by a factor of 1.5. So if I use, for example, -w 1920 -h 1080, it gives me a 2880x1620 window, with a 1920x1080 resolution but with all the pixels scaled up to 1.5x pixels, making them look blurry. On a 4k monitor, this still isn't that bad looking, but it would be nicer to have 1-to-1 pixels. Is there some setting in the config files that will force the game to think the monitor is 3840x2160?
      steamcommunity.com/app/362890/…ns/0/1693785669854252232/

      The post was edited 1 time, last by RedEye9 ().

    • Just a long shot, but ask the user to check if mat_viewportscale is set to something other than "1.0".

      You'll get a 1.5x upscaling if mat_viewportscale "0.666667" and mat_viewportupscale "1".

      On a side note, mat_viewportscale doesn't work well with the December Beta update. Changing mat_viewportscale messes up the new dynamic lighting engine, and the console gets spammed with "ERROR!! - Secondary View NewLights RT SIZE MISMATCH VIEWSIZE [...]" error messages.

      EDIT: I say long shot because I don't think mat_viewportscale will affect the size of the window, just the in-game rendering resolution.

      The post was edited 1 time, last by Flavrans ().

    • Ah, OK. I was about to post a follow up post saying to scratch my previous post as I figured out that it could be a DPI scaling issue.

      For some reason, when you run Black Mesa in windowed mode, the window gets scaled (stretched) according to the scaling setting in Windows Display settings (including -noborder had no effect on this on my system).

      There are two ways to work around this:
      1. Set the display scaling to 100%, or
      2. Enable the "Override high DPI scaling behavior" setting in bms.exe Properties -> Compatibility, and make sure "Scaling performed by:" is set to "Application".