This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    Logging in with you Steam ID has now been restored ♥

    • In the April update, is there any particular reason why I'm not able to add $treesway to some existing models, like models/props_foliage/mall_tree_medium01.mdl? I should be able to locally have a VMT of the same name that adds those settings, right? As a local test, for that tree specifically, I tried adding VMT in bms/materials/models/prop_foliage/mall_trees_branches02.vmt. The vmt looks like this:

      Source Code

      1. VertexlitGeneric
      2. {
      3. $baseTexture "models\props_foliage\Mall_trees_branches02"
      4. $AlphaTest 1
      5. $AlphaTestReference ".35"
      6. $nocull 1
      7. $model 1
      8. $FlashlightNoLambert 1
      9. "%keywords" l4d2
      10. $treeSway 2
      11. $treeSwayHeight 512
      12. $treeSwayStartHeight "0.5"
      13. $treeSwayRadius "256"
      14. $treeSwayStartRadius "1.0"
      15. $treeSwaySpeed "0.050505"
      16. $treeSwayStrength "0.020205"
      17. $treeSwayScrumbleSpeed 3
      18. $treeSwayScrumbleStrength "0.101"
      19. $treeSwayScrumbleFrequency 4
      20. $treeSwayFalloffExp 5
      21. $treeSwayScrumbleFalloffExp 7
      22. $treeSwaySpeedHighWindMultiplier 6
      23. $treeSwaySpeedLerpStart "2.0"
      24. $treeSwaySpeedLerpEnd "6.0"
      25. }
      Display All
      But the changes don't show up in-game. However, if I change aspects of this VMT (like disabling AlphaTest), the changes do show up in Hammer. So, I'm confused. I also tried this using leaves.vmt, which is used by bush01_dead.

      I also tried doing this in bms/custom/(nameofmap)/materials/models/prop_foliage/mall_trees_branches02.vmt. Didn't work. There is no motion at all.

      As a point of reference, I have a bushsm.mdl model in my test map which is blowing around as expected, as it does in the main game.

      So, what's wrong? Am I putting these in the wrong place?
      Recent work: bm_bravado, bm_oasis