Black Mesa Mod Publishing tool Guide - How use and edit workshop submissions.


#21

I’m not sure if this could help developers fix the bugs or not, but it looks like this sound loading bug only happens with reupload. So if I upload a completely afresh sound mods, it works well, it’s probably why Chon’s mod works - he uploaded it the first time and hasn’t updated anything. But the second I either update the files or just re-upload the mod after deleting the original, it’s doing this. Even deleting workshop cache files didn’t fix the issue, though.


#22

I don´t know. Last summer I updated my previous version of my sound mod and seemed to work fine.


#23

Ok, so it looks like you’re trying to overwrite files that the game either doesn’t properly identify, or we’re not letting you for reasons. If I can get a chance later today, I’ll take a further look at the mods and see if I can help out. For the sound mod, load it up and type “snd_restart” in console, and see if that helps you.


#24

snd_restart worked for my sound pack, it even loaded those bsp´s that are in the mod. My menu mod worked only partially, it loaded the sounds but not the background. And when I disabled the console, both my mods went mute again.


#25

I meant reupload since the Crossfire update. I just suspected this because I uploaded my mod and it worked well (it was post-Crossfire too), and I proceeded deleting it and then re-uploaded the updated files (kind of like you did) and then it started doing this. It could be a freaky coincidence though.


#26

Just browsing through the workshop:

I’d like to remind everyone to check their workshop contribution list on their steam profile and check for an empty, nameless, imageless black mesa file. If you have one, PLEASE DELETE IT. If you’re having problems with the workshop tool, removing the blank addon WILL help.

Also, I’m loving a lot of the mods that are coming out recently!


#27

Recently? You mean you’re not a fan of poorly recolored crowbar #517?! That’s a classic!


#28

To be honest, there was a Candy Cane one I really liked.


#29

Uploading OCPD.vpk from a “staging” folder in the main “bms” directory seems to be destroying my cubemaps. Is there a specific folder maps should be uploaded from in order to preserve the cubemaps?


#30

Black mesa publish not work!


#31

For some reason the publish tool won’t open for me, I’ve had issues in the past with it not opening but it’s always been resolved by opening it in admin mode, steam running/not running etc.
Now it just won’t run.


#32

I have the same problem.


#33

Same problem for me.


#34

I’m looking into this now.


#35

It’s a bit of a pain (a lot of a pain if you have a slow internet connection), but you can restore the publish tool to its old glitchy-but-useable state by going into the public-beta tab of the preferences and selecting “Rollback to Crossfire Update”.

I wouldn’t recommend compiling maps under that mode, though, as a lot of assets and other things were changed- just upload your mod and switch it back.


#36

glad you made it, @AdmiralSakai!


#37

I also posting this message here because this situation is really frustrating.

I’ve followed your advice Admiral Sakai. I’ve created a “Black Mesa 2” folder with the Crossfire Update version and I can now upload my add-on with this folder, after compile it with the last version of the game.

But even with this, I’m afraid a large part of add-on of the workshop don’t work in the game anymore. I’ve tried during three hours with a sound mod and a translation mod. The .vpk files of the game have the priority, whatever you try.
And the only other “result” I’ve had is not working. By “result”, I mean the game plays neither the sounds of my mod nor the original sounds.

The only actual way to make correctly work a mod, is to use this trick apparently:
https://steamcommunity.com/sharedfiles/filedetails/?id=502670746

The sound mod:
http://steamcommunity.com/sharedfiles/filedetails/?id=441958970


#38

Good idea, though, putting the entire CU2 game in a separate folder. I was waiting for the entire game to update whenever I wanted to upload, and then resetting to the latest release when I was done.


#39

Is it possible to make a script mod that changes values in skill.cfg with the Workshop? I made a “Half-Life 1 Ammo Values” script mod but it doesn’t work when I subscribe to it.


#40

This probably falls under a longstanding issue with the Black Mesa mod system that keeps custom script files from working. A number of things are rendered impossible by this, but the devs say they are working on it.