Black Mesa v1.0 - Large list of bugs etc. from first playthrough w/ images (March 21st 2020)

I didn’t want to play through this game til it left early access so I could go through it in all its v1.0 glory, but naturally I found some bugs so I figured I would compile a list of things I encountered. Here is my v1.0 general bug report based on my experiences from start to finish (spoilers for new content ahead). I have zero modifications installed, and was playing on Hard:

I regrettably have not been getting the getpos info for these but I’ll describe where they’re located in addition to posting screenshots.

Not sure if the G-man is like this (shootable) in every area, but in “We’ve Got Hostiles” after the slippery floor w/ elevator shaft and turrets, you’re able to leave bullet holes in him, which doesn’t trigger his walking animation so you can shoot him as much as you’d like from a distance:

In “Residue Processing”, once you enter the facility from outside and you see a security guard run into a doorway, if you climb up the tank in that first room and enter the vent, there is a transparent vent brush that definitely shouldn’t be there:

Just above one of the main pump levers in the blue area of the Lambda Complex, A large segment of railing has no clipping:

Also in the Lambda Complex in one of the giant pools of water (still before entering the reactor area) is a pipe going straight down into the middle of the pool which ends abruptly with no texturing:

The HEV suit models in Xen (scientist ragdolls and zombies) have a misaligned and backwards chestplate texture, which you can see here:

During the first stage of the Gonarch battle, I was healing and grabbing rockets on that island and one of its projectiles hit a crystal and floated there indefinitely. It also didn’t hurt me when I touched it and I couldn’t get it to go away:

This is not really a bug, but it was something that bugged me. No pun intended. I didn’t notice the things spewing gas out of them for a bit because the huge pools of oil and fumes had me under the impression that I was supposed to light either one of those. It’d be nice if the flares triggered these flames as there are huge clouds of gas that seem like they should definitely light up:

Escaped a segment in Interloper where I was supposed to be locked in, in an attempt to flee from controllers to find the last healing station I used. I believe this was the result of falling an extremely long distance way back to the beginning of the map. I definitely fell down somewhere I wasn’t supposed to; I remember jumping over some wall. I tried to climb back up but there was a locked door blocking me from doing so. I believe I escaped somewhere near that rotating cylinder that you have to go underwater to bring an acid barrel into, but I’m honestly not sure. Not really any point in mentioning this one as I forgot where it happened but it was something anyone could replicate:

Random bugs and opinions without screenshots:

-The default Half-Life 2 magnum bullets box is annoying me a bit. Please take the time to update the model and texture for that (use the original HL1 design found here?: https://combineoverwiki.net/wiki/.357_Magnum )
Every time I look at it, it just feels out of place amongst all the redone models and materials. Some people have already done this in the workshop but it would be nice if it were done officially.
Same goes for the very recognizable G-man model from HL2. Looks dated up close during the end sequence.

-The crossbow also loses its crosshair when zoomed in, and many shots I take result in a bolt stuck in the middle of the screen, blocking my view entirely until I zoom out, even if the bolt isn’t getting stuck on invisible walls, which is what I thought the issue was at first. I’d landed shots and not known it til I zoomed out to get the ass-end of a bolt out of my face. I have disabled ironsights for the magnum (they feel out of place to me if I can’t use them on all the guns, thanks for adding the option) if that is relevant to this issue.

-The gauss gun will charge forever and not fire if you attempt to use a charged shot with a low ammo reserve.

-The Egon fires forever if you zoom in while firing, but it does no damage in this state.

-I carry extra items around a lot so I can waste them and have backups right away. I noticed in Blast Pit while cycling silo door airlocks (to leave or enter the center hub of the silo) that my held item disappeared, and that the lighting changed drastically. I was under the impression I was in a sneaky teleportation room every time I hit one of those door buttons.

-While travelling to the (orange area) pump activation lever in Lambda Complex, I was running past the rubble and dead scientist with a medkit in my hands. I was slightly annoyed that the medkit disappeared but that’s kind of to be expected sometimes with loading points, but the actual issue I had here was that I got stuck in the ground and had to load my previous save. Don’t know if it’ll happen every time but I thought I’d mention that.

-I have also had the “landing jets” text appear at the bottom of the screen the entire game randomly after going through loading points. No idea why.

-The new zombies in Xen are really cool but it bugs me how impervious they are to firearms (invincible to bullets even? I shot a ton of rounds into one to test it out and it seemed to do absolutely no damage- the Egon worked just fine though) when not aiming for the head. Just reminds me of how quickly I die to regular arms fire when being shot at by HECU grunts and I’m stuck wondering “why the hell do their suits work and not mine?” I am also unsure of what the blue sparks are supposed to be when I land headcrabshots. Shouldn’t it just be blood?

-The huge elevator sequence leading up to Nihilanth was probably the only notably laggy part of the game for me. It wasn’t laggy 100% of the time but during some of those midpoints I was getting like 5 FPS for short periods of time. My hardware is a bit old but it usually runs everything I throw at it without many issues. I had the graphics on high, and I use a GTX 970 and a 2013 A10 Black processor w/ 16 GB of RAM.

-During the Nihilanth fight I got stuck in the floor a couple times in the exact same spot. I think I was standing in a location where he was trying to make the ground come up / teleport a building segment into.

Hope some of this is useful. Thanks for the fun game!

1 Like

In Blast Pit there is a little storage room where Gordon collects a crank wheel. The metal box in the corner next to the door is not solid.