Bms.exe has stopped working

I downloaded game from Steam but when i try run the game it comes with “bms.exe has stopped working”.
Problem Event Name: APPCRASH
Application Name: bms.exe
Application Version: 0.0.0.0
Application Timestamp: 5b27e9a9
Fault Module Name: StackHash_0a9e
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Code: c0000005
Exception Offset: 00000000
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1049
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

I tried restarting PC, download DirectX, Microsoft vcredist, run with -autoconfig, -windowed -noborder launch option. Nothing worked. Please, help me.
System Specs:
OS: Windows 7 x64
Graphics Card: Nvidia 2060
RAM: 16GB
Processor: Intel Core i5-750
Motherboard: ASRock H55M-LE
I played Black Mesa a few years ago, maybe on Win XP, I’m not sure. Since that i reinstall the system and changed graphics card, but nothing else.

Nevermind, already solved:
Solution: first delete from d3dx9_24.dll to d3dx9_42.dll inclusively from the System32 and SysWOW64 folders, and then use the DXUpdate utility to install the missing d3dx9_dll.
It also helps with error 0xc000007b!