Ear ringing sound Effect - Fix possible in player.cpp


#1

Hello dear developers.
Please me a favor and just set this to false:
bool ear_ringing = distanceFromPlayer < MIN_EAR_RINGING_DISTANCE ? true : false;
https://github.com/ValveSoftware/source-sdk-2013/blob/master/sp/src/game/server/player.cpp

I and a lot of other people hate this sound effect.
If you don’t want to remove it, please make it an option :slight_smile:

https://steamcommunity.com/app/4000/discussions/1/490123727974086656/
https://steamcommunity.com/app/320/discussions/0/598198173699323912/
https://facepunch.com/showthread.php?t=1355524
https://forums.alliedmods.net/showthread.php?p=2409439

Playing with multiplayer with this sound, while having a headset really sucks.


#2

Also couple if times happened to me during intensive combat that ear ringing does not stop (or high frequency filter) and reconnecting to server is necessary to make it vanish.


#3

I would vote towards making it optional instead of removing it.
I like post-blast tinnitus as a detail. (I also miss the old HL2 “underwater” sound which was removed, I believe, around 2007.)

That said, apparently in DM it can linger after respawn, which is a bit of an issue. Haven’t run into the bug myself, but if it’s still an issue it needs to be looked at.


#4

This is still in the beta, can we get an option to disable it? At least in singleplayer.

Sincerely, the guy who hates the sound.