ED_Alloc: no free edicts

ED_Alloc: no free edicts

I am getting this error message everytime I load a saved game. I am in the Interloper lastest maps, in some sort of tower with lots of annoying shielded controllers.

1 Like

I had this issue, the only work around seems to be to load an earlier save, and try to get through it without dying. Even if they come out with a proper fix, that savegame is pretty much ruined anyway. Sorry if it’s not much help.

Didn’t they fix this in the most recent update?

Anyway, what worked for me was to save when it’s “quiet”, i.e. when there are no enemies around. Then proceed, and don’t die until you’ve killed all enemies in the next arena, and then save again. The saves saved in this manner wouldn’t crash the game for me at least.

  • Fixed the “no free edicts” crash in map D.

In order to continue my game progress, I loaded the map. It is bm_c4a3d.

Strangely, I didn’t get to reproduce the error.

Fortunately, other people got the same issue, so it will be fixed, I guess.

I’m still getting this issue now. Thought it would have been patched out by now. Tried setting graphics to minimum and no luck.

Edit: Loaded up a much earlier save, played forward from there, and bug is not reproducing now where it used to. Thanks CC for patching that! :smiley:

Are you in public beta branch? Do you have mods installed? What is your ram size?

Ah, loaded up a much earlier save, played forward from there, and it’s working great now where it wasn’t before. All good! Thanks CC for patching this! :smiley:

I’m getting this problem I’ve had to go back to the end of Gonnarchs Lair because none of my Interloper saves would get beyond the error. Is this far enough back to stop the problem reoccurring?

Having the very same issue with the official release… I’ll try loading the map directly, but it really is painful…

1 Like

Just wanted to report that as of today this is still happening, that is, I got this far in Xen and it’s happening to me. Editing the launch parameters doesn’t do anything. I went back 2 saves and got the same result. So it’s in need of a fix, since having to back up and start over from a previous spot, even if it works, is hardly a solution to a serious bug. I hope support is listening. Thank you for your support.

1 Like

I am getting this too. Can’t get past it.

2 Likes

I see there are a lot of complaints on the BM Steam discussion board under the “Bugs” thread. I’ve also seen bad reviews on PC Gamer left by customers for this same error.

The “solutions” being pinned or recommended by forum moderators are not working and as such are disingenuous at best. The bug has been on-going for nearly 2 years, based on the dates on the Steam discussion board. It is not uncommon.

Discussion board moderators offer ideas such as Developer Console hacks which need to be entered by the customer. I find this unreasonable. The problem was created by bad code and it needs to be fixed at the source-level. The error is a game-stopper and renders the game unplayable.

I wish I could offer solutions … but none of those offered to date work for me and I have all but given up on this game working. No disrespect intended to Crowbar … just the facts.