[FAQ] Semi-complete Black Mesa FAQ - READ FIRST


#1

===

[COLOR=‘Cyan’]Q1: What are the real minimal system requirements for Black Mesa (from here on would be referred as BM) to get almost lag-free gameplay experience?
A1: You would need a videocard with a decent peak fillrate and a fast enough CPU with at least two cores. Memory requirements are at least 512MB of video card onboard memory (preferably of a GDDR5 kind; or at least of GDDRx kind and not an ordinary DDRx one) and about 1GB of free system memory available for game engine to use. Low frequency quad core CPU would perform worse than high frequency dual-core or triple core CPU.

Aim for 3GHz+ Intel Core i3/i5/i7 or 3.5GHz+ Athlon II/Phenom II or 3.8GHz+ AMD FX or AMD Socket FM1/FM2 AXX CPUs to be on a safe side. With Core i5/i7 and AMD FX CPUs SMT had been reported to cause performance regressions sometimes. You might wish to disable HyperThreding of your Intel CPU in motherboard system BIOS setup utility or set your AMD FX CPU to advertise one core per module if you happen to experience CPU-related performance issues in BM.

As for recommended GPUs: so far I have tested how does the game perform with nVIDIA chips I had on hand. Basing on my personal experience and of a reports on forums from other people GTX480 or GTX580 or GTX670/680 would work well. SLI configurations had also been reported to work well – i.e. it’s OK to use 2xGTX460 or 2xGTX560, and dual-chip cards like GTX490/590 would also work well. Expect some micro-stutter and worse minimal FPS with SLI – this is a typical problem for this technology.

[COLOR=‘Cyan’]Q2: I’ve got a slower GPU/CPU than listed in the answer to the previous question. Would I still be able to play BM?
A2: Yes, but you would hit FPS dropdown problems at some places throughout the game. There are some workarounds though that could allow you to play the game moderately well in case you had been able to play HL2:EP2 or Portal II with a good enough frame rate on your rig. This workarounds would be listed later on in this FAQ.

[COLOR=‘Cyan’]Q3: I’ve downloaded the game and now don’t know how to install it. All I’ve got is a ~3GB file with 7z extension. What should I do?
A3: Your download is incomplete. Complete game installation package consists of the three files, one being 7z archive with the game itself, another being an md5 checksum which allows game installer to verify the integrity of the installation package and this is the executable allowing you to install the game. It is possible to manually unpack 7z archive but it is “kind of advanced” topic which would not be covered in this FAQ. Also you should have Steam and Source 2007 SDK installed to play this game (both are free). If you don’t know what the Steam is or how to install Source 2007 SDK – google for it, there are a lot of information about these topics all over the internet.

[COLOR=‘Cyan’]Q4: I had installed the game using its installer and now can’t find it anywhere – there’s no desktop icon for it, there are no entries in Windows Start Menu, e.t.c. How do I start up the game?
A4: This game is a modification (mod) to be played with Source 2007 SDK. To play mods like you should start up Steam client application, navigate into “Game Library” tab and there you’d find “Black Mesa” waiting for you to start playing. If you happen to have Steam running at the moment when you install BM and you can’t locate BM in the Steam’s game library - try restarting Steam client and it should appear in the library games list.

[COLOR=‘Cyan’]Q5: I’m having troubles with starting up the game: it either immediately crashes at start with a “hl2.exe stopped working…” message (Windows 7/8 or Vista) or with a “The program has performed an illegal operation and will be shut down.” (Windows XP) or displays some error message like “Failed to create D3D Device”. What to do?
A5: First of all, check that you’re using latest version of the GPU drivers for your videocard. Next, you could try adding “-window” to the BM command line parameters in steam (right click on the “Black Mesa” entry in Steam games library, select “Properties” and then press the “Set launch options…” and paste “-window” to the edit box. It it hadn’t helped – try using “-fullscreen -width -height < your monitor native resolution height>” there. Still no luck? Try puting “-dxlevel 90 -window” there. If nothing helps – check (if you could) if other Source-based games like original Half-Life 2, HL2: EP1, HL2: EP2, HL: Source, CS: Source, Portal, Portal II, Team Fortress II do not suffer from the same problem. If they are – report a bug to a Valve’s support. If not – read instructions here and report your problem to these forums: http://forums.blackmesasource.com/showthread.php?t=12513

[COLOR=‘Cyan’]Q6a: I’ve got some strange visual glitches in game like pink checkerboard-like textures on some objects (NPC eyes, Freeman’s hands) or a white line crossing the screen diagonally from one corner to another. What’s wrong?
[COLOR=‘Cyan’]Q6b: I want to use switch the engine into using another DirectX version, what should I do?
A6: For a some reason you have the game running in a DirectX 8.0 or 8.1 mode. It is a legacy renderpath that is supported by the Source 2007 SDK engine but is not properly supported by BM. You have either to switch the game into using DirectX 9.0+ mode or to get used to play with visual artefacts as they are. You could workaround diagonal white line crossing the screen by disabling HUD post processing in the “Black Mesa” tab of the game settings menu. Be sure to also disable chromatic aberration post processing filter while you’re there if you intend to continue playing in DX8 mode (or you would get the entire screen temporarily go black when something hits you).

To check what renderpath does the game engine use go to the “Settings”->”Video”->”Advanced…” from the main game menu and check the contents of the “Hardware DirectX level” text box. It should state DirectX v.9.0 or 9.5 or 9.8 for the game to work as was intended by developers.

In order to switch the engine into using another dxlevel you should quit the game and then edit BM startup command line by specifying “-dxlevel XX” there. XX should be one of: 80, 81, 90, 95 or 98. You really shouldn’t use 80 or 81 unless you have really good reasons to do it and you really know what are you doing. You’re on your own with dxlevel 80/81, bug reports for this renderpath are not welcome and seems to be considered invalid. On Windows XP you should use either mode 90 or 95. There shouldn’t be much difference between those modes really but you might have slightly better performance with dxlevel 90 in case your GPU is pretty old one (like GTX 8800/9800 or GTS 250). DirectX level 98 is intended to be used with DirectX 10 compatible videocards under Windows Vista and up accessed through compatibility D3D9 layer. There shouldn’t really be any difference between dxlevel 95 and 98 on Vista+ so you’re free to chose and use any of these. But in case you’re on Vista/Seven or Windows 8 and experience some troubles with dxlevel95 – try switching to dxlevel98. Chances are it might help (but I doubt it).

After you start up the game with the dxlevel specified on the command line be sure to check that the game had actually switched into using specified dxlevel by checking the contents of the “Hardware DirectX level” box in the advanced video settings dialog. In case you’ve got the engine switched to the level you want – make sure to quit the game and remove “-dxlevel XX” from the BM command line. Forgetting to do so would result in game resetting most of the video settings to the default values each time you restert the game – which is not convenient at all.

[COLOR=‘Cyan’]Q7: The game micro-stutters like mad as soon as I try to move. I have vsync turned on.
A7: This problem had been reported to be caused by trying to use multithreaded materials rendering which is in theory supported by the Source 2007 SDK engine but de-facto is pretty broken. Open up in-game console and execute (i.e. type in and press enter):

mat_queue_mode 0

Also you could try disabling vsync and check if that helps.

[COLOR=‘Cyan’]Q8: I’ve got a lot of “freezes” in game: sound starts to stutter and game does not reacts on keyboard/mouse input. After a second or two the game unfreezes continues on normally. What’s wrong?
A8: There are several known causes for this problem. First of all, make sure to update the soundcard drivers to the latest available version. Then, configure your default sound output device to use “Stereo speakers” or “Headphones” mode and make sure you have the same setting chosen in the game audio settings dialog. If this don’t help – time to start experimenting. Try adding “-nosound” to the BM command line parameters and check if the game freezes the same way without sound. If it don’t – try specifying “-primarysound” in the command line parameters instead of “-nosound” and check if that helps. If not – try “-wavonly”.

If the game freezes the same way with the sound turned off – try moving your Steam installation to another storage (preferably to a fast SSD) and try defragmenting your hard drive (in case you use HDD and not SSD).

If nothing helps – try playing with downgrading GPU drivers to an earlier stable release or try using bleeding edge beta GPU drivers. Also make sure you don’t have any of the system components overheating (CPU, GPU, motherboard chipset hub). If you’re overclocking your CPU and/or GPU – revert them back to a fabric-default settings and check if it helps. If you’re on Windows Vista, 7 or 8 – try disabling Auro desktop theme.

If you had tried everything and nothing helped – bad luck for you. If you happen to find a way to fix you problem that was not mentioned here – please, report it so I could include it in the FAQ. Thanks.

[COLOR=‘Cyan’]Q9: I’m playing the game and it works fine in general but sometimes FPS drops down really low. What to do?
A9: BM happen to be really tasking both on the CPU (physics, dynamic lighting, particle systems simulation, geometry processing) and on the GPU (fillrate, dynamic lighting, triangle setup). Most frequently encountered tasking situations are fillrate-constrained effects like smoke clouds in the test chamber right after the cascade resonance and dynamic light calculations that are being done when marines or sentry guns shoot at you or when you set zombie on fire. Less common troubles are water reflection coupled with a lot of highly detailed geometry rendering or physics-related CPU tasks (tentacle in the blast pit known to cause it). While the general answer on how to remedy this problems would be “get a better CPU/GPU” it is not something that you want to hear, aren’t you? Well, you could get by using the following command added to the end of autoexec.cfg of your BM installation:

[code]
texture_budget_panel_x 550
texture_budget_panel_y 112
texture_budget_panel_height 450
texture_budget_panel_width 512
budget_panel_x 0
budget_panel_y 50
budget_panel_height 900
budget_panel_width 512

alias BudgetShow “sv_cheats 1; +showbudget; showbudget_texture 1; alias BudgetToggle BudgetHide;”
alias BudgetHide “-showbudget; sv_cheats 0; showbudget_texture 0; alias BudgetToggle BudgetShow;”
alias BudgetToggle “BudgetShow;”
bind b BudgetToggle
bind n “incrementvar texture_budget_panel_global 0 1 1”

alias DynamicOn “r_dynamic 1; r_dynamiclighting 1; alias DynamicToggle DynamicOff;”
alias DynamicOff “r_dynamic 0; r_dynamiclighting 0; alias DynamicToggle DynamicOn;”
alias DynamicToggle “DynamicOff”
bind “u” “DynamicToggle;”

bind “j” “incrementvar r_WaterDrawReflection 0 1 1;”
bind “m” “incrementvar r_drawparticles 0 1 1;”[/code]

With these commands in place as soon as you hit FPS dropdown you (a) should press “B” and take a screenshot, then press “N” and take yet another screenshot and then check what bar had the most length on the graph you’re presented with. Most of the times you would have the longest bar displayed against “Dynamic_Light_rendering” - and to remedy this you should press “U” on your keyboard. As soon as you do it you this bar should shrink to a minimum. If the longest bar is next to “Swap_Buffers” label and there are a lot of smoke/sparkles effects displayed on screen – press “M” and check if that helps. If the longest bars are next to “Static_Prop_Rendering”, “Other_Model_Rendering” and there’s a bar of a noticeable length next to “CViewRender::Render” - try pressing “J” and see if that helps.

To hide the budget panel (red thingy with a bar graphs) press “B” once again and continue playing. As soon as you think you had passed by the FPS problematic area – press “U”, “J” or “M” once again to turn related effects back on. Be sure to only press “U”, “J” or “M” second time in case you had pressed it before to “fix” FPS drop. This keys act like switches: when you press them for a first time they disable related effect and when you press them for the second time they enable the effect back and so on. “U” controls dynamic lighting, “J” - water reflections, “M” - particle effects.

When you finish your play session – make sure to collect all the screenshots you had captured for problematic FPS areas and post them to these forums among with the detailed info on your hardware and software configuration. It would allow developers to pinpoint the most problematic places in game from the performance PoV and hopefully fix it somehow in future updates.

[COLOR=‘Cyan’]Q10: I’ve got a multicore CPU and experience a low FPS and/or a lot of stutters in BM despite my system being way higher than the requirements posted in the answer to the Q1 of this FAQ. Is there a way to fix it?
A10: You might wish to try changing CPU affinity for the hl2.exe process in the Windows task manager. Some people report that setting affinity to use 3 out of 4 cores on quad core CPU had “fixed” stutters problems for them. Some other report that limiting hl2.exe to only use one CPU core works better for their case. Latter one has some ground with last generation of Core i5/i7, AMD Phenom II x6 and AMD FX CPUs – ensuring that OS won’t endlessly move the execution of the main game thread from one CPU core to another might allow Turbo Boost/Turbo Core technology to do it magic effectively reducing in-game CPU pressure. You could find more detailed info on how to set CPU affinity at this sticky thread:
http://forums.blackmesasource.com/showthread.php?t=12660

[COLOR=‘Cyan’]Q11: I’ve heard that one could use tweaked configuration file for BM to get it perform way better than with default settings. Is that true?
A11: Well, yes an no. There are some things that could be tweaked but don’t expect to get “huge performance increase” as a result. Here is the config I use to play the game on GTX 550 Ti with 1GB VRAM coupled with AMD FX 8120 CPU and 16Gb DDR3 system RAM:

[code]cl_showfps 2
fps_max 62

mem_max_heapsize 3000
mat_alphacoverage 1
mat_compressedtextures 1

mat_specular 1
mat_bumpmap 1
mat_parallaxmap 1
mat_queue_mode 0

r_threaded_particles 1
r_threaded_renderables 1

snd_async_fullyasync “1”
snd_mix_async 1
dsp_slow_cpu 1

cl_predict 1
cl_smooth 1
cl_forcepreload 1
sv_forcepreload 1

fog_enable_water_fog 1

r_dynamic 1
r_dynamiclighting 1
r_maxdlights 16

m_filter 0
hud_quickinfo 1
r_flashlightdepthtexture 0

rope_smooth 1

texture_budget_panel_x 550
texture_budget_panel_y 112
texture_budget_panel_height 450
texture_budget_panel_width 512
budget_panel_x 0
budget_panel_y 50
budget_panel_height 900
budget_panel_width 512

alias BudgetShow “sv_cheats 1; +showbudget; showbudget_texture 1; alias BudgetToggle BudgetHide;”
alias BudgetHide “-showbudget; sv_cheats 0; showbudget_texture 0; alias BudgetToggle BudgetShow;”
alias BudgetToggle “BudgetShow;”
bind b BudgetToggle
bind n “incrementvar texture_budget_panel_global 0 1 1”

alias DynamicOn “r_dynamic 1; r_dynamiclighting 1; alias DynamicToggle DynamicOff;”
alias DynamicOff “r_dynamic 0; r_dynamiclighting 0; alias DynamicToggle DynamicOn;”
alias DynamicToggle “DynamicOff”
bind “u” “DynamicToggle;”

bind “j” “incrementvar r_WaterDrawReflection 0 1 1;”
bind “m” “incrementvar r_drawparticles 0 1 1;”

alias +walk “sv_maxspeed 120;”
alias -walk “sv_maxspeed 320;”[/code]

You should adjust at least mem_max_heapsize to match the amount of the memory available on your system: in case you have less than 8Gb you should really lower this value to something like 1500 or 2048. If you have 2Gb – set it to 1024 or even to 768. You might have to experiment a bit with it. Or simply comment out this line and let the engine use default value.

Also you might with to include “-preload” in BM startup command line parameters – it isn’t required and is expected to force the same engine precacheing behavior as “cl_forcepreload/sv_forcepreload” do but it won’t hurt having it there either.

[COLOR=‘Cyan’]Q12: Where could I find autoexec.cfg and config.cfg that are used by BM?
A12: They are located at: \steamapps\sourcemods\BMS\cfg

[COLOR=‘Cyan’]Q13: Jumping height seems to be too low and don’t match what it were in original game. Could it be fixed?
A13: Navigate into BM configuration files folder and edit skill.cfg file. Find a line stating “bms_normal_jump_vertical_speed” and set the value you want there. Repeat the same for “ bms_normal_crouch_vertical_speed”. Many people all over the internet seems to use these values as their preferred defaults:

bms_normal_jump_vertical_speed "200" bms_normal_jump_crouch_vertical_speed "200"

You should really tweak this ones in order to match your personal preferences. But I advice not to change these as you would have to use the default once if and when the deathmatch version of BM would be released.

[COLOR=‘Cyan’]Q14: Slow walking toggle seems not to work at all. Is there any way to fix it?
A14: Include the following hack in your BM’s autoexec.cfg:

alias +walk "sv_maxspeed 120;" alias -walk "sv_maxspeed 320;"

Be warned that it won’t help you to safely crouch/walk near the tentacle in the blast pit level – game engine seems not to match the original tentacle behaviour of the HL. So you still would have to use grenades or other explosives to distract tentacle in order to pass that area of the map.

[COLOR=‘Cyan’]Q15: Game difficulty seems to be a bit too hard on normal, is it?
A15: Well, it is a matter of a personal preference. IMO monsters reaction time is a bit too fast and accuracy and LoS range seems to be way longer than it should (at least for marines) but there are a lot of games out in the wild who think that monsters are too easy as they currently are. I’d suggest switching to the easy skill level if you feel that the game is too punishing for you and makes you into a “save/reload whore” behaviour. Alternatively you could tweak some thinks in skill.cfg a bit, like damage coefficients for headshot or arm/legs. In the original game headshot was dealing triple damage compared to the normal corpse shot and arms/legs shots had been dealing the same level of damage as corpse shots. In BM by default head shots deal twice the damage of the corpse shot and arm/leg shot deals 80% damage of the corpse shot. You could change it to make in line with the original like this:

sk_npc_head "3"
sk_npc_chest "1"
sk_npc_stomach "1"
sk_npc_arm	"1"
sk_npc_leg "1"

It would made the game a little bit easy to play.

[COLOR=‘Cyan’]Q16: I get some strange visual glitches or sudden game crashes. How to fix it?
A16: It depends. First of all, BM seems to be extremely picky to a way you change render-related settings. If you want to change texture detail level or to disable HDR rendering – make sure to save the game first, then execute the “disconnect” command in the in-game console, then do the desired changes and then quit and restart the game. If you simply change the setting in the middle of the play session and continue to play on – expect the game to crash in the near future.

There are no definite answer on how to fix it really – so simply get used to quit and restart the game as soon as you change some sound or video related setting.

You could also hit some sporadic crashes not related to settings change. There shouldn’t be a lot of such kind though so simply restart the game and continue playing. Make sure to upload crash minidumps to these forums after you finish playing so devs could investigate the problem and hopefully fix it in future patches.

[COLOR=‘Cyan’]Q17: I’ve got a lower-end videocard (like GTX 450/550/550 Ti) and can’t afford enabling MSAA due to severe performance drop. Is it possible to use postprocessing based antialiasing techniques with BM?
A17: Yes, you could use SMAA/MLAA/FXAA injectors with BM. Place injector d3d9.dll into \steamapps<your steam username>\source sdk base 2007\bin, all other files like “injector.ini” or “SMAA.fx”/“SMAA.h” should go to \steamapps<your steam username>\source sdk base 2007. It seems that some keys can’t be used to control injectors. For injectSMAA I use the following injector.ini config:

[code][injector]
;toggle shader keycode
key_toggle = 44

;make screenshot keycode
key_screenshot = 122

;reload shader files keycode
key_reload = 19

[smaa]
;smaa preset one of {SMAA_PRESET_LOW, SMAA_PRESET_MEDIUM, SMAA_PRESET_HIGH, SMAA_PRESET_ULTRA}
preset = SMAA_PRESET_ULTRA

[misc]
;set to 1 to improve steam overlay compatibility
weird_steam_hack = 1[/code]

It allows to turn SMAA on/off by pressing Pause/Break button and to take BMP screenshots through injector using Print Screen. Screenshots are not that important though as Source 2007 SDK engine is perfectly capable of capturing screenshots on its own.

Note: make sure you don’t use D3Doverrider to force vsync/triple-buffering for hl2.exe. It won’t work with SMAA injector. What you’d get would either no triple-buffering forced by D3Doverrider or no SMAA injected by SMAA injector.
Note 2: Set “Antialiasing” to “None” in the game advanced video preferences dialog and do not force MSAA though GPU driver control panel. If you would try to use SMAA having “Antialiasing” set to anything but “None” in game you would end up with SMAA producing no visual results but eating up your GPU fillrate. If you try to force AA in game using GPU driver control panel while have antialiasing disabled in game you would end up with broken in-game reflection and refraction effects.

[COLOR=‘Cyan’]Q18: When I start a new game, the mouse starts out acting normal. If I press any key on the keyboard, the mouse goes into a mode where it acts like a joystick. That is, when the invisible pointer is to the left of center, the player turns left constantly. Same for up, down and right. The movement gets faster the more the pointer is off center. Centering mouse stops movement. What’s wrong and how to fix it?
A18: Do you have a mouse/keyboard sharing between several different computers program named “Synergy” installed on your PC? If so - it’s most probably is the cause of the problem. Report a bug to “Synergy” developers and disable/deactivate it prior to starting the game. Thanks to nex for reporting this problem and thanks to physco827 for sharing this solution.

[COLOR=‘DeepSkyBlue’]… FAQ Continued HERE …[/SIZE]

[COLOR=‘Cyan’]P.S. Sorry for grammar and spelling errors: English is not my native language. Comments and suggestions are welcome.


#2

Updated, added Q18 entry about the mouse input problems related to the “Synergy” software.


#3

I’ll add my 2 cents if that’s okay.

[COLOR=‘SeaGreen’]Q 1: I can’t get past a certain area, or when I am playing, the game suddenly crashes at ‘x’ location in ‘y’ level. This always happens. What can I do to get past this area?
A 1: Don’t post here, post a separate thread and then you should try and provide a bit of video to show us, which you can upload to Youtube. Use the free program ‘Fraps’ to record your issue. You can try to change your graphics details to the lowest possible playable settings, just to get past the problematic area you have encountered. Then simply set them back to what they were before and see if you still get problems. Also please make sure to include a ‘minidump’ with you as an attachment to your thread/post. It makes a big difference and in many cases can instantly show what went wrong and how the issue could be fixed. Your minidumps are in this location: “C:\Program Files (x86)\Steam\steamapps<username>\source sdk base 2007” they look like “hl2_4104_crash_2012_9_16T23_11_15C0.mdmp” etc.

[COLOR=‘SeaGreen’]Q 2: The game crashes really often when going through any loading screens. This happens sometimes/often. What can I do?
A 2: This can happen when the player is doing something through the loading screens. For instance, shooting/reloading/throwing grenades/jumping etc. Just walk through normally and wait.

[COLOR=‘SeaGreen’]Q 3: I’m having problems with the game crashing the moment I click ‘Play’ in Steam. The message is ‘hl2.exe has stopped working’ How do I fix this?
A 3: Install the SDK 2007 and the game Mod (when asked to in the installer) into a really short directory like “C:/Games” or “C:/BMS” the game tends to complain when installed on x64 bit systems because there are brackets/non alphanumeric-characters in the file-path eg. “()”. Doesn’t help? Then are you running Windows 8? See the bottom of my post.

[COLOR=‘SeaGreen’]Q 4: I have found a bug/glitch in the game, that does not affect me completing the game, or enjoying it, what do I do?
A 4: Make a new thread and detail it. Provide a video or pictures if you can. This isn’t a serious issue as the game is only v1.0 and you can still play as normal. Also remember to include a minidump, as I stated in the first point of my post.

[COLOR=‘SeaGreen’]Q 5: When I turn the fan on in Silo D the game crashes either as the fan spins up, or when it gets to max speed. Help!?
A 5: Others have stated that it’s probably a physics glitch and some have reported that smashing all of the boxes and/or throwing all of them and the barrels down past the fan into the abyss has prevented the game from crashing. You could always try getting out of that area as quickly as possible, and making for the next loading screen.

[COLOR=‘SeaGreen’]Q 6: I’ve been messing around and I am stuck and can’t proceed. Help!?
A 6: This is an easy one, just reload a save sorry and post a thread about what you did that made you stuck in the first place. Hopefully it will be fixed in an upcoming patch. No promises though. Also include a minidump, and the more ‘visual evidence’ video/screenshots the better.

[COLOR=‘SeaGreen’]Q 7: It takes quite a long time to get past loading screens, what can I do to speed this up?
A 7: Let Steam degfrag your game files so the loading screens are shorter. BMS tends to have pretty long loading screens even on very good computers. Or manually defrag the files yourself and place them somewhere on the outer pallet of your drive if you are using a mechanical HDD.

[COLOR=‘SeaGreen’]Q 8: Turning on the flashlight crashes my game and/or causes other undesirable effects. Help?
A 8: Other players have reported that lowering shadow quality has fixed this for the time being, and then putting it back in another level. Also there are reports of nVIDIA drivers having a bug in later releases making flashlight and/or shadows to be rendered incorrectly on GeForce 7XXX GT(X) video card series. It is not yet known what version of driver to use to workaround this problems, last two “stable” releases (from 306.XX and 301.XX branches) are bugged for this cards. Upd. There is a report that using driver 168.16 with 7xxx series nVIDIA cards fixes the problem. I suspect that it’s possible to find a bit more fresh version that would also work well, but knowing the version that works is a good start. - Thanks lexa2 for the previous points.

[COLOR=‘SeaGreen’]Q 9: My game shits itself and I lose lots of FPS whenever I see smoke or dust or mist or other particle effects. What can I do?
A 9: You might not have the CPU power to process these effects. Post processing and particle effects are pretty heavy tasks on a CPU. You’ll at least need a dual core for tasks like that. Turn your particles settings down. You could also bring down the console and see if you get any ‘object drawing errors’ in the location that you’re in.

[COLOR=‘SeaGreen’]Q 10: I have tons of screen tearing whilst playing, it looks like a loading .jpg or something. Is there a fix?
A 10a: Turn on V-Sync your FPS is too high for your monitors refresh rate and your screen is tearing. If you experience lag after turning on V-Sync then turn off Triple Buffering. If you experience input lag after turning on Triple Buffering then you need a better computer. It’s normal for many PCs that aren’t totally incredible to have their frame rate drop under 60 (or whatever your refresh rate is) in scenes with intense effects or whatever. eg. Firefights and Outdoor areas. V-Sync will drop your frames a little (hopefully not too much) and still prevent screen tearing in areas where your FPS gets too high. While some people report that the amount of input lag is tiny, others with a high DPI mouse who are used to playing FPS games with a high level of sensitivity may find that the amount of lag will irritate them. It’s really up to you how you want to balance screen tearing in smaller areas where your framerate may go over your monitors refresh rate, vs. the chance at a couple of ms. of lag. All in all, the problems can be fixed by getting better hardware, and/or hopefully after a few patches comes out. With decent hardware the game is completely ‘finishable’ without tearing or lag however.

A 10b: Lexa2 suggested this:

So to get minimum amounts of input lag and vsync at the same time:
a) Limit FPS to slightly above 60 FPS. Easiest way for Source engine is to include fps_max 58 in autoexec.cfg.
b) Use D3Doverriter to force-enable vsync and triple buffering.
c) Be sure not to force vsync off in the videocard driver control panel. Also be sure that - in case driver control panel allows to set this setting - “Maximum pre-rendered frames” is set to at least 2 in order for “triple-buffering” described here to work.
d) Play in fullscreen mode - current nVIDIA drivers seem not to vsync properly vsync in case you have multiple monitors and run your app in window.
e) Make sure you do not change any in-game gfx settings without quiting the game right after that and restarting it back - D3Doverrider seems not to be able to force triple-buffered render queue mode upon D3D context re-initialization the game does on the gfx settings change. - Thanks Lexa2!

[COLOR=‘SeaGreen’]Q 11: The game plays almost perfectly, but it’s still a little stuttery… help?
A 11: Have you tried overclocking your hardware? If you have good cooling, and know what you are doing you could try overclocking. It can make a big difference, or no difference at all. Don’t worry too much if your game experience is almost perfect, in overclocking your RAM. Just go for the GPU and if that doesn’t provide enough of a performance gain, then overclock your CPU. The limits in which you should overclock your hardware depends on what hardware you have and what cooling you have and is not something that anyone here can give you advice on. Google “, and it”. Just make sure you understand the risks first. While some may say that overclocking will increase instability and not necessary do anything at all, it’s up to the user, and the hardware as I said. It’s really a ‘hit or miss’ kind of situation. You can end up with better performance, and games that weren’t playable, suddenly are. Or you can end up making things worse. If your hardware IS overclocked, try the opposite. Put your hardware back to stock-clock settings and see if it plays better.

[COLOR=‘SeaGreen’]Q 12: I have ‘any Intel graphics’ and want to play BMS, will it work?
A 12: I personally would say, “Absolutely not”. There is no kind answer. Intel graphics are not suitable for playing anything really. Maybe at a low resolution you could play a little. It depends. The short, sure-fire answer is no. I don’t consider ‘Intel’ or ‘Integrated’ graphics good enough to allow ‘fluid’ gaming without constant slow-downs, jitters and other issues. Intel cards have a low texture fill-rate, and really aren’t for gaming. You can play Counterstrike Source and a few other really low-key games, but the point here is that you really cannot expect much if you have one of these chips.

[COLOR=‘SeaGreen’]Q 13: I have a laptop with ‘Nivdia Optimus’ or a dual GPU setup ATI configuration, and the game plays like crap, what the hell?
A 13: Most likely your computer is set to use the ‘Intel’ or whatever low-powered GPU you have installed. Instead of your high powered one. Go into your Nvidia (or other applicable) settings and change the default graphics processor to your Nvidia/ATI chip then restart your computer and try playing the game again. Also make sure that BOTH your Intel and Nvidia chips have the latest drivers.

[COLOR=‘SeaGreen’]Q 14: I want to play the game in a language other than English. Can I do this?
A 14: Read this: http://forums.blackmesasource.com/showthread.php?t=13016 You’ll probably find your answer there. There are people working on it now.

[COLOR=‘SeaGreen’]Q 15: Omg the music is amazing how can I get the soundtrack for it it?
A 15: Here. You could have always googled it Lazy bum… don’t forget to tip the producer. He worked 7 long years on creating it.

[COLOR=‘SeaGreen’]Q 16: Why can’t I find an option for DX 10?
A 16: The game was built on an Engine created in 2007. It doesn’t even support Multicore rendering. There is unfortunately no way to play the game with DX 10 graphics.

[COLOR=‘SeaGreen’]Partially related to the Q&A:

Many users are reporting issues with Windows 8. Including issues where the game doesn’t even start in the first place. At the moment we’ve got an RTM (release to manufacturing) edition of Windows 8 available. It is in no way a ‘Finished copy’ of the operating system. We had the same deal with Windows Vista and Windows 7 before they were commercially released. The drivers available for Windows 8 are in no way ‘finished drivers’ and one cannot expect the same stability from these drivers when running on Windows 8, as opposed to Windows 7.

Before the Nvidia forums went down there were a lot of people complaining about some games not playing ‘out-of-the-box’ on Windows 8 as well as Windows 7 allowed them to. This included random gameplay errors, exits, freezes, the game not starting at all as well as other undesirable problems whilst playing some games. If one is to still contact support and ask “Which set of drivers is more compatible/reliable with most games” one will still get the answer that Windows 7 drivers on a Windows 7 platform are the better choice.

If one is to go over to the AMD/ATI forums and ask about the compatibility of Windows 8 vs. Windows 7 drivers, as well as the reliability of both, one will get the answer that Windows 8 drivers should not be expected to perform with the same reliability as Windows 7 drivers. [COLOR=‘Red’]However many people will not experience any problems on Windows 8, and it is very hard to tell if some of the problems you could be experiencing, are to do with you running Windows 8 or not.

Before the Nvidia forums went down. I asked the staff and other members what I should expect from my Nvidia hardware and they said while the drivers have the capability to perform with excellence, but that there are still a lot of problems that need ironing out. “A new operating system brings new opportunities but also new problems” I was told.

A lot of people here are having problems with the game playing under Windows 8. This can be found by doing a search for Windows 8 in the bug reporting part of the forums here. One thing you could still try is to go back to Windows 7. To ensure no problems in the future the absolute best thing you could do IN ANY CASE where you will be trying out a ‘proof-of-concept’ operating system. Is to make a DUAL-BOOT configuration so you can easily and accurately test the performance of the game on Windows 7 vs. Windows 8. In any case when ever want to try something out, you will have both a stable and the newest partially stable system to try the game in question out on. Of course one should never rely on having ANY ‘RTM’ non-commercially released operating as the only OS available on their Computer.

In the end this is a 7 year old game, that was made on an Engine created in 2007. Back when Windows XP was the most popular OS. Windows 8 may or may not cause problems in itself whilst trying to play ‘Black Mesa Source Mod’. As I stated before, some users may never experience problems with it, others may. It’s just a very grey area at this point…

<<-- Always updating -->

[COLOR=‘Red’]Peace and good luck with enjoying one of the best shooters this year has to offer!


#4

That’s OK but it would be easier for us if you number your questions somehow (like Q-II-1:, Q-II-2 and so on, to distinguish with ones in the first post) so we could refer to them when posting links to the FAQ in answers to other forum threads.

IMO it should be added once again that including minidumps and complete details on software and hardware environment is absolutely crucial. You know, all that reports like “Help, I’m stuck after I played a bit and the game crashes, help, help, please, bump, anyone?” without any further details - it really makes me rant about it.

IMO it’d be better to rephrase this one a bit: users should have their Steam installation placed without having some nonsense in path like “Program Files (x86)” or non-alphanumeric characters. I.e. answer could be something like: “Move your Steam folder to the root of the drive or to any other place making sure path to it would be short (less than 128 symbols - it is a limitation of the relative path length for some filesystems - VFAT namely - on Win XP) and do not contain spaces, national alphabet characters and punctuation. “C:\Games\Steam” would be a good choice.”

Also there are reports of nVIDIA drivers having a bug in later releases making flashlight and/or shadows to be rendered incorrectly on GeForce 7XXX GT(X) video card series. It is not yet known what version of driver to use to workaround this problems, last two “stable” releases (from 306.XX and 301.XX branches) are bugged for this cards. Upd. There is a report that using driver 168.16 with 7xxx series nVIDIA cards fixes the problem. I suspect that it’s possible to find a bit more fresh version that would also work well, but knowing the version that works is a good start.

It’s not CPU which is limiting factor here, it’s huge amount of overdraw for some (not yet optimized) effects using up all the available fillrate of the videocard. Budget panel would show longest bar against “Swap_buffers” for these cases, especially if you zoom your view into the particle effect which causes troubles.

The part about input lag is somewhat wrong here. Triple buffering when implemented properly in the engine do not cause much extra input lag (usually it is about ~8ms on average - which is something most people won’t even notice). hl2 does not implement triple buffering properly. What D3Doverrider and tools like that allow to force in the games is not really a proper triple-buffering, it is rather 2 or more depth render queue. It remedies from the 60-30-60 FPS stutters problems related to ordinary double-buffered vsync but it also causes 2 or more (equal to the queue depth) frames input lag if your system is capable of performing rendering way faster than at 60 FPS rate. With 2 depth render queue input lag would be on average in 32-40ms range - and that is easily noticeable by most players. As a comparison, with ordinary double-buffered vsync extra input lag usually in 8-16ms range - somewhat noticeable but not THAT bad.

So to get minimum amounts of input lag and vsync at the same time:
a) Limit FPS to slightly above 60 FPS. Easiest way for Source engine is to include fps_max 58 in autoexec.cfg.
b) Use D3Doverriter to force-enable vsync and triple buffering.
c) Be sure not to force vsync off in the videocard driver control panel. Also be sure that - in case driver control panel allows to set this setting - “Maximum pre-rendered frames” is set to at least 2 in order for “triple-buffering” described here to work.
d) Play in fullscreen mode - current nVIDIA drivers seem not to vsync properly vsync in case you have multiple monitors and run your app in window.
e) Make sure you do not change any in-game gfx settings without quiting the game right after that and restarting it back - D3Doverrider seems not to be able to force triple-buffered render queue mode upon D3D context re-initialization the game does on the gfx settings change.

TL;DR version of answer: Do you overclock your hardware? If yes - don’t do it, or stop complaining of forums about misbehaving game if something breaks for you. Overclocking means unpredictable instability, reporting bugs against overclocked systems is a waste of time.

Not strictly true. Latest HD 3000/4000 variants actually allows to play many D3D9-age games and console ports with ~30-60 FPS having quiality settings set to medium or low. But in general people trying to play games using Intel GPUs should be warned that they are on their own and should expect FPS dropdowns, input lags and lots of other problems related to bugs in Intel drivers which were known to be even more buggier than ATI/AMD ones.

P.S. Leijonasisu, thanks for your additions. It’s nice to see that there are people with good knowledge of IT here on these forums.


#5

You may also have to restart the Steam client before “Black Mesa” shows in your “Game Library”
Edit: if the Steam client was running while you installed “Black Mesa”


#6

Yeah, forgot about that one, thanks. It’s really possible for one to have BM not appear in steam game lib until here/she restarts the Steam client. Would add into about it to the first post in a minute.


#7

For Q/A 15, the Reaction times can be slowed down.

respectively:
ai_reaction_delay_alert
ai_reaction_delay_idle

Double (programming nerd’s speak for decimals I.E. “0.3”) numbers are in seconds I.E. 0.1 = 1/10th of a second. 0.1/0.3 are the values as defaults.

However be aware that the values being changed will affect AI universally. This may also fix a few problems with trying to take cover with vorts.


#8

[COLOR=‘DeepSkyBlue’]… FAQ continued …[/SIZE]

[COLOR=‘Cyan’]Q19: As soon as I turn the flashlight on the game crashes or some other undesirable effects happen. What to do?
A19: There were reports from several players that reducing shadows details to “Medium” or “Low” and disabling HDR usage (setting it to “None”) could help with this problem. It seems that most of the times flashlight-related game crashes affect people using AMD Radeon HD 6xxx/7xxx with drivers versions from 12.4-12.8 range. It was reported that downgrading to earlier versions of the driver might help. Also there was a report that resetting CCC settings to defaults and then turning off Catalyst A.I. and texture filtering optimizations helped at least one user to fix this problem. As a last resort measure you could try temporarily switch the game into using dxlevel 80/81 as described above in this FAQ.

Note: make sure to restart the game after changing any of the video quality settings.

[COLOR=‘Cyan’]Q20a: Flashlight don’t work as it should: it light up some in-game objects but has no effect on walls. I’m using nVIDIA 7xxxx GT/GTX GPU. Could it be fixed?

[COLOR=‘Cyan’]Q20b: I’ve got problems with shadows being rendered incorrectly: they look like rectangular completely black areas under the objects instead of being soft shadows as they should be. I’m using nVIDIA 7xxxx GT/GTX GPU with 306.xx drivers version. Could it be fixed?
A20: Flashlight problems with GeForce 7xxx GPU series and fresh driver versions seem to be a driver-related bug. It is not yet known what version of driver is a first one to introduce this bug but there was a report that using driver 168.16 fixes the problem. I suspect that it’s possible to find a bit more newer version of the driver that would work well but knowing the version that really works is a good start.

[COLOR=‘Cyan’]Q21: Why does some preferences I set in “Black Mesa” tab of “Options” dialog are not saved between game restarts and are always reset to their defaults? Is there any way to fix this problem?
A21: It is known bug in BM, there’s no real fix for this (yet). As for now, you could use some workarounds like one described in this thread: http://forums.blackmesasource.com/showthread.php?t=14280 (thank you them1ke for posting this).

[COLOR=‘Cyan’]Q999: I’ve got a question (and the answer) related to a problem which is not covered in this FAQ. Can you help me?
A999: Maybe. Try searching forums first for your problem, chances are you’re not alone with it and someone had already found and posted a solution. Feel free to contact me in case you had found a BM-related problem and a solution to it that is not covered by this FAQ, I would be happy to include it here.


#9

TBH I hadn’t been able to notice any change in AI behavior even if I set these to some huge values like 5-10 seconds. Marines and vorts seemed still to charge/react on player almost without delays so I’m not that sure BM’d AI implementation really uses these cvars internally. I can’t tell for sure due to not being able to look into server side source code for obvious reasons. Thus I hadn’t included information about these cvars into FAQ.


#10

This is completely false. The FPS drops can’t be fixed by using more modern hardware (even guys with 690s have these), the cause for them seems to be a combination of old tech (the 2007 Source SDK) and bugs (in the issues where the fps drops to high 20s after reloading a quicksave - e.g. where you are first attacked by assassins). The mod simply uses tech that the engine can’t handle, the solution to this can only be two thing: pushing Valve to release a new SDK and porting Black Mesa to that ASAP or the Black Mesa team coming up with particle and smoke effects that are more suited to the engine and fixing bugs that cause performance drops.


#11

I’d agree with you in general unless there won’t be a reports on forums with the proving screenshots of the most problematic places showing that some people with powerful hardware seem not to have THAT major FPS drops compared to people with less powerful hardware. And your second part about “old tech” is simply incorrect - the age of the engine isn’t the problem here, but rather is the way it’s used sometimes. To make is simple: if you try to draw huge amounts of alpha-blended polygons to the screen you would have a lot of performance problems as soon as you would cross the maximum fillrate capabilities of the hardware you have. This problem is a hardware usage pattern and it would affect new engine the same way it affects older.

Thus it is not “mod uses too modern tech to be handled by the older engine” but rather “the mod using capabilities provided by the engine in a way they are not meant to be used or is using them in a generally unoptimized way”. And I doubt that porting mod to the new release of the source engine would auto-magically “heal” all the problems: several things like fillrate shortage due to huge overdraw with particles systems or slowdowns caused due to using a lot of complicated prop_static geometry is something that hits the hardware limits (either CPU and GPU) and the only real remedy would be (a) to use way faster hardware than is available nowdays in average PC or (b) optimize problematic places of the mod so it won’t hit hardware limits that badly. For both cases (a) and (b) speedup would happen no matter the version of the engine used.


#12

From what I tested, 285.62 are the last drivers with fully working flashlight and normal shadows on GF 7xxx GPU.


#13

Thanks for the constructive input lexa2 and congratulations on the sticky. I’ve been a little busy just finishing up my second play-through. I’ll be able to post my updated findings and etc. based on the current topics and other in-game stuff I’ve found within the next few hours. (As well as make the applicable changes that you mentioned) :slight_smile: Have a lovely rest of the week everyone and enjoy the game!


#14

Really awesome FAQ, thanks so much!


#15

First of all, thanks for the amazing FAQ and for all the very informative replys, lexa2 - I really do appreciate it!


Now, to my ‘suggestion’ / ‘addition’ (call it what you want):

Since relatively many people have reported NPCs falling through the ground after they’re killed (mainly because their games are restricted, in some way), I wanted to add something to the thread’s context.

Which is this:

Important: [COLOR=’#E37024’]This is not a (real) fix! I can not guarantee that it works for everybody! Please be aware of that, when reading and / or using it. Thank you.

If you’re having trouble with Non-Player-Characters (NPCs) falling through the ground or just disappearing after they’re killed, enable the console (details below) and type in these commands (one-by-one):

Remember to hit ENTER on your keyboard before proceeding to the next command!

Useful commands (“violence_???”):

violence_ablood 1
violence_agibs 1
violence_hblood 1
violence_hgibs 1

Breakdown:

violence_ablood - Enable (1) / Disable (0) particle effects for blood on NPCs of alien origin (Detail: Violence _ Alien Blood).

violence_agibs - Enable (1) / Disable (0) gibbing effects on NPCs of alien origin (Detail: Violence _ Alien Gibs).

violence_hblood - Enable (1) / Disable (0) particle effects for blood on NPCs of human origin (Detail: Violence _ Human Blood).

violence_hgibs - Enable (1) / Disable (0) gibbing effects on NPCs of human origin (Detail: Violence _ Human Gibs).

To enable the console, do this:

[i]

  1. Close Black Mesa.
  2. Open Steam.
  3. Browse to the Library (All Games).
  4. Right click “Black Mesa”.
  5. Click “Properties” (on the bottom of the menu).
  6. Click “Set Launch Options…”.
  7. Type “-console” (without “”).
  8. Click “OK”.
  9. Close the "Black Mesa - Properties" window.
  10. Start the game.

[/i]


I guess that’s it. I hope it is detailed enough… :blush:


#16

You are welcome.

Unfortunately it won’t help for gamers having their Steam account marked as being a “resident of Germany”. But people for who this is a case could try using two workarounds: (A) create a new dummy Steam account having no games assigned to it and use it to play BM or (B) try using “change AppID trick”. Details on (B) are easy to find using forum search function and I don’t think including them in FAQ is reasonable as there were reports that changing AppID could introduce other problems like Black Mesa disappearing from Steam library or hl2.exe failing to start reporting “This application is not available now . Try again later.”

Or simply go to Main Menu -> Options -> Keyboard -> Advanced -> Enable developer console (~).


#17

It appears that I am a “resident of Germany”, which is why I posted this addition.

After I had tested and seen in-game that it works, I started writing the reply / post above.

[COLOR=’#808080’]Maybe I should’ve added that it is not a guaranteed fix and that it might not work for everybody. (Done)


#18

Thanks for clarifying. It’s pretty strange though as there are several reports on forums stating that changing these had no effect for people living in Germany and suffering from this problem. I can’t test it for obvious reasons as I live in a different country so, yep, it seems to be yet another case of YMMV.


#19

[COLOR=‘Red’]Stick to the topic guys. Leave the rants about Windows 8 elsewhere.


#20

I still must use other appid (like 109).

I think this only occurs when someone alters gameinfo.txt content.
But, all I need is to change appid inside steam.inf (then restart Steam). I have blood, gibs, ragdolls…
We don’t need changing gameinfo.txt