[FIX] Possible fix for lagspikes and other peformance issues on quadc(or more) CPU's


#1

NOTE: Possibly only works with quad-core CPU’s or higher.

Problem:
Major lagspikes and stuttering, 100% usage of core 1 and the rest is pretty much untouched.
Unable to select anything at Multi-core rendering(no options to select).

Possible fix:
Get into task manager.
Click the processes tab.
Find the hl2.exe process.
Right click > Set Affinity… > select all cores but one


#2

Sticky


#3

You can press OK then go back to Set Affinity and select again.
Had that issue with HL2 years ago and did the same. Then Valve fixed it. But now it’s here, again…


#4

Fuck yes.


#5

I’m not seeing regular stuttering, it’s usually fine, but occasionally it will hang for half a second to two seconds or so, much like it had trouble loading a resource.

The affinity trick made it better, but it still happens pretty regularly.

I have also tried these tricks to no success: http://hardforum.com/showthread.php?t=1717116


#6

Is there any fixes for dual core machines? I’m running a Core 2 Duo with an Nvidia GeForce 9700M GTS. (Laptop)


#7

I change the affinity from Task Manager and I still can’t choose anything from the Multicore rendering? I have Athlon II x4 640.


#8

It’s not supposed to fix that…


#9

This had no noticeable effects for me, but kudos for posting it, i’m sure it’ll be of help for many others


#10

didn’t work for me but this did

http://forums.blackmesasource.com/showthread.php?t=13209


#11

Didn’t work for me
but this did

http://forums.blackmesasource.com/showthread.php?t=13281


#12

I had lots of audio pops and sound loops that would briefly freeze the game.

I did the following and got much more smooth performance:

In Steam, right-click, Properties on the Black Mesa icon. Set Launch Options…
I set -heapsize 1048576
That’s to allocate 1 GB of RAM to the heap.

I also made the following changes to my autoexec.cfg file in C:\Program Files (x86)\Steam\steamapps\sourcemods\BMS\cfg. You can test these without editing the file in the developer console.

[code]snd_mix_async 1
snd_async_fullyasync 1

cl_forcepreload 1
[/code]
The first two made a huge difference for me. The last one (coupled with the heapsize change) improved load times somewhat. snd_async_showmem will also show which .wavs are preloading.

My system:
Intel Core2Duo E6550
8GB DDR2
AMD Radeon HD5770

edit: I had this in there but not sure it’s doing anything meaningful. Cache seems the same size regardless.
snd_async_minsize 393216


#13

Here is what i did

http://forums.blackmesasource.com/showthread.php?t=13281


#14

So, I am getting this issue with horrific fps in spots (including when you get to the surface… 10-15 fps no matter what setting you choose for graphics). I have quad-core and a modern video card. The multicore rendering is unavailable to be selected… and my Core 1 usage is 100%…

…and this ‘Set Affinity’ trick does not help. :frowning: Is there any way to force Multicore Rendering on?

Awesome mod, btw.


#15

Disabling Hyper-Threading in the BIOS settings fixes stuttering for me in HL2 on my i7 2600 but Black Mesa seems to be a whole other kind of animal. There are small stutters when the mod seems to be loading new scripted events and stuff like that. A lot of mods act like this for me (just tried Nightmare House 2 and it does the same thing) so this may be an issue with the SDK.

However there are other problems with Black Mesa such as some huge fps drops thanks to unoptimized effects, e.g. the beginning of Unforeseen Consequences can get down to 30 fps if I go into the smoke at the beginning. Hope these get fixed soon.

For the time being all we can do is trying the usual things, for example I noticed that the Black Mesa install is a little fragmented, running Contig fixes that.

TheGhost: Multicore Rendering is broken for Half-Life 2, it’s better to turn it off, for example I get half the fps when I turn it on (having 250-300 fps with multicore rendering disabled, 140-150 when it’s on). It’s probably a blessing that it’s not available for Black Mesa.


#16

I find that the finale fight in Lambda Core is the heaviest taxing on my system. I get 80-90 fps in most cases but when all the lights start up in the finale, I drop to about 7fps. Too many particle effects for even good computers?


#17

mat_queue_mode 0
should do the same.


#18

For all owners of nVidia GPU with such issue I recommend to update driver to last one which came out 2 days ago.
Suddenly it gave me crazy improvement of fps (100-120 instead of 25-60)
I dont use Affinity trick anymore coz its not necessary.
No idea how GPU can be related to CPU, but new driver really fixed it.


#19

The suggested:

Launch parameters:
-heapsize 2097152

In game:
snd_mix_async 1
snd_async_fullyasync 1
cl_forcepreload 1

Seems to be helping. It does stutter on occasion, but seems much less frequent.


#20

A lot of people seem confused; you should add to the OP that this isn’t meant to address the issue where the “Multicore Rendering” option is empty. That’s an issue with the engine: Source 2007 doesn’t have multicore rendering implemented.