Flashlight's issue


#1

First of all: sorry for my bad english

When I press F, the command that activate the flashlight, I can only hear the sound of that, but the flashlight doesn’t lights up.
There’s a command in the console or other that can fix this problem?


#2

Steam Black Mesa Discussions


#3

I just spent over $700 dollars on a new computer so that I could play, and low and behold, the flashlight doesn’t work. Anyone have a link to known fixes for me? I am still learning how to navigate these new spiffy forums.


#4

The link is right above your post :wink:

Can you provide us with some specs?

  • Is it a laptop or a desktop? (I’m assuming desktop).

  • Does your computer have a dedicated graphics card? If not, try adding these commands to the game launch options:

    -force_vendor_id 0x10DE -force_device_id 0x1180 -dxlevel 95

    You’ll need to remove -dxlevel 95 after you’ve run the game once with these launch options, or the game’s graphics settings will reset to default every time you launch the game.

  • If it is a laptop with a dedicated GPU (graphics card), make sure you are running the game on the dedicated GPU, and not the Intel integrated GPU (use the control panel for the graphics card to set the default GPU for bms.exe).


#5

Twasnt sure that was going to still be the most valuable troubleshooting available. Thanks for verifying that it is tho! I turned added that first line to the launch options and it looks like the flashlight works! woot!

Dell Inspiron 3670 Desktop Computer, Intel Core i5-8400 Processor 2.8GHz; NVIDIA GeForce GTX 1060 3GB GDDR5; 8GB DDR4-2666 RAM; 1TB Hard Drive.


#6

According to your specs, you have an NVIDIA GeForce GTX 1060. To my knowledge, that workaround shouldn’t be necessary in your case, it’s only meant for those who have to run the game on an Intel integrated GPU. This may be a silly question, but could it be possible that you have connected your display to a display connector near the other I/O ports (in which case you would be using the Intel GPU), and not one of the display connectors on the GeForce GTX 1060 card (in the expansion slot area at the back of your computer)?

You can also check which driver the game has loaded by typing mat_info in the console, scroll upwards a bit and look for “Driver Description”. It should say something like “NVIDIA GeForce GTX 1060”, and not “Intel…” something.


#7

Hubby was the one to plug everything in, so now I am wondering if in fact this is what he did! haha! Thank you for the feedback!