Game only using one core and HDR slowdowns

#1

I’ve checked cpu logs and only my first cpu core being used, and also the multicore rendering option is blank.

Running i5 3570k @ 4.2GHz
8GB RAM
GTX 670 OC
128GB SSD
306.23 (latest drivers)
DX9 and 11 installed.

Also HDR and Glow effects makes the game extremely choppy, around 20-30fps when HDR is enabled.

I really doubt it’s my system not being able to handle the game.

0 Likes

#2

Weird. I’m running an i7 processor (slower clock speed, though), but only a GTX258 in the GPU arena. Regular hard-drive, and 6 gigs of ram…

Things are running fine [all options at High or Highest, all dropdowns at their highest, all visual options enabled]. However, I have been keeping away from the newest drivers (the latest releases almost always cause bugs for me, heh). But I think you need them for that card.

Yeah, just checked, it’s not stuck on one core. It seems you have a… special situation.

0 Likes

#3

I’ve tried setting affinities to anything but core 1, and the game instantly crashes.

Also tried mat_queue command to 2 1 and 0, nothing seem to work.

Guess I’ll just play something else, it’s broken for me.

0 Likes

#4

Are you using sli? (I have seen a few people report that disabling sli in the nvidia control panel, removes any lag on high end machines)

0 Likes

#5

Not using SLI.

Is multicore rendering implemented into Black Mesa?

EDIT: NVM, just saw BM is built on the 2007 source engine, which means it doesn’t utilise multicore rendering.

0 Likes

#6

I have quite similar specs:

3570k @ 4.0GHz
4GB RAM @ 1600MHz
Evga GTX 670 OC
306.23

The only slowdown I had was near the area where you see the first guard who is shooting a zombie just after Resonance Cascade. The room next to that with the zombie banging on the window and the lights are flickering, but I still only lose about 2/3 frames according to fraps.

0 Likes

#7

I also have a problem mentioned in the topic. Game uses only one core, at the freezer area in the office complex it freezes and then the screen goes black.

my specs:

athlon II X3 445
8800gt
creative x-fi soundcard
4gb of ram
win 7 32 bit

0 Likes

#8

The game will only ever use 1 core to render. It is a single threaded application. No matter what the computer, how great, or how weak, your primary core will be maxed. This is not a problem.

If you are having issues with bad performance, I would first suggest you try lowering your graphic settings.

0 Likes

#9

Is there any chance that Valve will supply you with 2009 engine for Greenlight project, which will lead to multicore support and maybe Mac OS support?

0 Likes

#10

Lowering his graphics settings? What are you talking about, he has a machine that should easily handle Black Mesa. The thing is that the game seems to be pretty unoptimized on high end systems. I’m having better frames than him on my low-end laptop and that’s just silly.

Btw. great soundtrack! :slight_smile: The game is fantastic without any doubt, it’s sad it has issues like this.

0 Likes

#11

Hardware-wise, you’re absolutely right; I have slightly weaker hardware than you and I get 60 frames all day every day (with the highest settings and 4xMSAA).

But it’s definitely something on your system. Something about V-sync, your drivers, driver settings, some background application conflicting, etc.

For example, I often use D3DOverrider to force Triple Buffering in applications that don’t explicitly support it, but in BMS, it was causing some stuttering. I turned it off and used the in-game v-sync and voila! smooth video.

0 Likes

#12

Funny thing game work fine and then just get laggy, same with all seting mixed up.
Maybe i need and Sdk with this sdk base 2007 ? Or it is becouse i didnt donload and use MD5 with 7zip and exe files?

What you guys talking about Cpu cores, game use more than one . Look at http://wiki.blackmesasource.com/System_Requirements#System_Requirements

0 Likes