GUIDE: Setting up Source SDK for BM

I see some people asking for a guide on how to set up the Source SDK to make content for Black Mesa. If this was already posted somewhere, my apologies.

Here is how it’s done:

  1. Make sure Black Mesa, Source SDK Base 2007 and Source SDK are all properly installed. Run Source SDK at least once for it to create all the folder structures. Also run Black Mesa at least once, so you know SDK Base 2007 is properly installed.

  2. Go to your Steam folder (mostly in C:\Program Files(x86)\Steam). Then go to \Steam\steamapps\youraccountname\sourcesdk\bin\source2007\bin\ (where “youraccountname” is the name of your Steam account, of course)

  3. In this folder, find the GameConfig file. If you have never used SDK before, this file does not exist yet and you’ll have to make one yourself. Open the existing GameConfig or create your own by making a new Notepad file named GameConfig.

[COLOR=‘Red’]NOTE: Since it’s a text file, .txt should be the extension of the file. If you have hidden extensions for known files (which is default in Windows), just call it GameConfig. The extention .txt will be added by Notepad automaticly.

  1. In the GameConfig file add the following:
"Configs"
{
	"Games"
	{
		"Black Mesa"
		{
			"GameDir"		"c:\program files\steam\steamapps\sourcemods\BMS"
			"hammer"
			{
				"GameData0"		"c:\program files\steam\steamapps\sourcemods\BMS\bms.fgd"
				"TextureFormat"		"5"
				"MapFormat"		"4"
				"DefaultTextureScale"		"0.250000"
				"DefaultLightmapScale"		"16"
				"GameExe"		"c:\program files\steam\steamapps\youraccountname\half-life 2\hl2.exe"
				"DefaultSolidEntity"		"func_detail"
				"DefaultPointEntity"		"info_player_start"
				"BSP"		"c:\program files\steam\steamapps\youraccountname\sourcesdk\bin\source2007\bin\vbsp.exe"
				"Vis"		"c:\program files\steam\steamapps\youraccountname\sourcesdk\bin\source2007\bin\vvis.exe"
				"Light"		"c:\program files\steam\steamapps\youraccountname\sourcesdk\bin\source2007\bin\vrad.exe"
				"GameExeDir"		"c:\program files\steam\steamapps\youraccountname\half-life 2"
				"MapDir"		"c:\program files\steam\steamapps\sourcemods\BMS\maps"
				"BSPDir"		"c:\program files\steam\steamapps\sourcemods\BMS\maps"
				"CordonTexture"		"tools\toolsskybox"
				"MaterialExcludeCount"		"0"
			}
		}
		"SDKVersion"		"3"
}
  1. Now edit all the paths so they correspond with your computer’s set up. In other words: check where your Black Mesa, Half-Life 2 and Source SDK are installed and change the lines accordingly to that.

A more detailed look at the parameters:
GameDir = The folder where Black Mesa is installed.
GameData0 = Where the Black Mesa FGD file is.
GameExe = Where your Half-Life 2 installation is (the hl2.exe file)
BSP = Where the BSP compile tool is found. Make sure you use the one for SDK 2007.
VIS = Where the VIS compile tool is.
Light = Where the RAD compile tool is.
MapDir = Where you put your RMF files.
BSPDir = Where the BSPs need to be placed after compiling (BMS\maps folder).

[COLOR=‘red’]NOTE: If you’re editing an existing GameConfig file, look at the file’s layout first. See where sections begin and end (with brackets { / }). So if “Configs” and “Games” are already there, only copy the “Black Mesa” part somewhere between the other game configs. You also won’t have to put “SDKVersion” twice into 1 file. Make sure the existing “SDKVersion” is 3. If this is a different number, Hammer Editor won’t work properly.

[COLOR=‘red’]NOTE2: Pay attention to the “Program Files” folder. If you are running a 64-bit version of Windows, the Program Files folder is called “Program Files (x86)”.

  1. Save the file and then restart Source SDK. Then select Source Engine 2007 and you should see Black Mesa on the list.

And you’re done! :slight_smile:

If you have any questions, feel free to ask!

This should get stickied. Great guide! I’ll have to try it out soon.

Works perfectly, thanks! :slight_smile:

I second this.

Hmmm, I followed what you said down to the letter, But SDK claims to be unable to find the Gameinfo.txt file

Its GameConfig.txt not Gameinfo.txt i dont know if you just messed up the name in your post or whether you got it wrong on your computer as well.

Same

You’re right, I typed it wrong here, I did mean GameConfig.txt; and I’m doing what I can to try to fix the issue I’m having.

If anyone else is getting the same issue, and knows how to solve it, the help would be appreciated.

Let’s see if we can figure this one out :slight_smile:

If the game can’t find the file, than you’ve probably either placed it into the wrong folder or it somehow still has the wrong name.

Could you verify that it you’ve put it into the \Steam\steamapps\youraccountname\sourcesdk\bin\source2007\bin\ folder? and not in \Steam\steamapps\youraccountname\sourcesdk\bin\ folder?

In the correct \bin folder you should find all tools, like Hammer and Faceposer.

Second: did you read my note under the GameConfig.txt? If you have file extensions disabled (which is default in Windows), you don’t need to type .txt behind it. Windows will do that for you when you create a new Notepad file.

I’ve added a sample file which you can use.
GameConfig.txt (1.13 KB)

Sorry about my lack of knowledge on this subject, but which is the purpose of this guide? :slight_smile:

The Source SDK is the developers kit for all Source games, including Black Mesa.
By following the guide you’ll be able to use Black Mesa content in SDK and make custom maps for example. :slight_smile:

Thanks Hezus, I thought it’d be useful for lagspikes issue. :stuck_out_tongue:

why didnt you post this earlier? :frowning:

hehe, just kidding.

this should be usefull for those who cant configure hammer for BMS(like me)

Because the cheque didn’t arrive earlier :wink:

Thanks to the mod who stickied this!

Thank you so much for this!

I’ll try my hand on some maps, just for practice.

(Yes yes, I know they won’t be accepted into the game, meaning that the efforts would be invested fruitlessly; or so it would seem - but still, practice is always good!)

Possibly dippy question: Does it matter that my install of Steam stuck Source SDK 2007 by itself and not under \sourcesdk\bin\source2007 ?
I get the feeling the answer is “Yes” as well as “Wow, your Steam install really mucked that up, didn’t it?”

edit:
groan
Didn’t have the Source SDK, had SDK base '06 and '07… but not SDK.
Now I feel like a dope.

Hehe yeah, if you run Black Mesa for the first time it’ll automaticly install Source Engine Base 2007. But Source SDK will always need to be installed manually.

Maybe they won’t be accepted in the official game, but as we’ve all seen in the past: HL communities thrive on custom maps. As soon Deathmatch is implented, watch it take off :slight_smile:

Doesn’t work.

I’m getting an error every time I select Black Mesa and then Hammer. Here:

Setup file ‘gameinfo.txt’ doesn’t exist in subdirectory ‘c\program files(x86)\steam\steamapps\sourcemods\BMS’. Check your -game parameter or VCONFIG settings.

Do you know how to solve this?

This is how I fixed it:

  1. Open the Source SDK.
  2. Make sure both “Source Engine 2007” and “Black Mesa” are selected.
  3. Double-Click on “Utilities | Edit Game Configurations”.
  4. Click on “Edit…”.
  5. Replace the text inside the text-box of “Directory”, with Black Mesa’s location on your system ([DRIVELETTER]\SteamApps\sourcemods\BMS, for example).
  6. Click “OK”.
  7. Click “OK” again and start whichever Tool you need (Hammer, Model Viewer, Face Poser, itemtest).

Note: Replace [DRIVELETTER] with the corresponding drive letter (E: or C: or D:, etc.).

Note 2: Replace with Steam’s location on your system (such as: [i]D:\Program Files\Steam[/i]).

That’s about it, I hope that helps! :slight_smile:

Take a good look at the error message. You’ve spelled Program Files wrong. There should be a space in between. Also make sure the slashes are all the same. You use both slash and backslash.

If you want help, you should give more information or else we’ll not be able to do anything. Just saying “it doesn’t work” isn’t very useful, is it?