Hazard Course Remake (AVAILABLE NOW!)


#3221

It’s not just SteamPipe, it’s also the changes to the engine between the build used on BM mod version (SDK 2007) and the current engine (SDK2013[?]).


#3222

VPKs can pack up the files, sure enough. But putting the files in a VPK isn’t going to do you any good if the game is hard-coded to read the files from the default location, and the default location only, which it currently does… for a lot of files.


#3223

Not to mention it’s not even that the files are read from the default location, but that only the default files are read, period. If it was just the default location being read we could probably just upload the working stuff to the Workshop (mats, models, and maps which are the hefty majority of the files), and then a separate patch to get the rest working. But no, the game just disregards any modified files in some really important folders.

I get bitter every time someone says this. ^~^ Patch notes keep saying the tool was fixed but in reality something breaks between their internal tests and the changes being pushed to the public branch so the situation is never actually any different for us. But nobody realizes/knows that that’s the case, so they see the patch note and we always get questions. Plus, while the workshop tool being broken is a huge problem, the tool is actually the lesser problem. The above is the big one. That problems exists whether the tool is working or not.

Eh, not so much. For our intents and purposes they may as well be the same engine. I don’t think the engine change affected much for us outside the current issues, which seem to be Steampipe’s fault. (Also 2007 and 2013 are basically the same engine, but Steam Mesa runs on a modified TF2 branch, very different)


#3224

Okay, I don’t want anyone to get too excited, because further testing is required, but.


Berntaw (sp?) in BM.

Berntaw (sp?) in BM. WITH CUSTOM CHARACTER MANIFEST ENTRY.

Courtesy of the custom/ folder (some setup required)
Again, further testing is required for various script types, but this, combined with the workshop tools working in the beta branch of BM, is very much so progress. I have yet to try out the other required types, such as choreo and soundscripts, but if those are loading too now, I think we can have ourselves a steam course.

(Suck it, steampipe :slight_smile: )


#3225

It’d be incredible if we could actually get working custom scripts.


#3226

Murtaugh. :slight_smile:


#3227

Okay, further testing is completed.

Soundscripts, choreo, custom character manifests, etc. all load, meaning the Hazard Course works with the majority of its featureset. One caveat, there are some bugs we need to fix due to a few things (such as birds) not behaving the way they did in the mod version. There’s also one really big issue where if you have a weapon (not counting the crowbar) out and turn on the flashlight, the game up and crashes. Including in non-Hazard Course maps.
So no idea what’s up with that, aside from it also having happened when we tried to side-load the course a while back, but either us or CC are gonna have to figure out why that happens and find a solution.

Current Status: Non-functional, but situation hopeful.


#3228

It might be how the flashlight was done for BM. Wasn’t there some kind of thing where the player’s weapon would be casting shadows since the flashlight was pointed from behind the viewmodel? Or do I not remember rightly?


#3229

youtube.com/watch?v=exmj5AvJmlY

I was messing around with the game just now. Here’s a gift.

EDIT: spoiler warning, etc. etc. if you haven’t played Hazard Course yet this is spoilarz whatever oh come on who am I kidding everyone should have played this thing by now, right?


#3230

I’d go mad with that skype notification sound.


#3231

Have you tried VPK’ing your content? CU4 made it so that the game will prioritise VPK’d mod content over stock files - we removed functionality for mods shipping loose files as it was causing conflict issues and dramatically bloats load times if the game has to load even a single loose file.

I’m not sure if this will solve your issues with some files not loading correctly (our workshop programmer believes it will), but it might be an easier solution.

If you can debug and pin down the cause of your other issues and relay them to us, I might be able to get them into a hotfix if we have time.


#3232

Yes, we tried that several months ago (and I tried it again just now). The primary issue with that is that your workshop system seems to greatly dislike very large multi-part VPK files (which are required because HC is so big), leading to an immediate crash on game startup if you subscribe to the item. On the other hand, directly mounting the large multi-part VPK in gameinfo.txt seems to work perfectly fine.

Either that, or there’s something else we’re doing in our VPK that the workshop loader seems to really dislike.

I’ve PM’d you a link to the workshop item in question, if you guys wanna take a look.


#3233

Still have problem with sounds from workshop. Allways need snd_restart. Any solution?


#3234

Yeah, I have a solution. Post in a relevant thread.


#3235

Boycotting HC on grounds that it is abusive and disrespectful towards birbs, who’s with me


#3236

I’ll get our workshop programmer to take a look at this, thanks. Will get back to you when I can.


#3237

I did more experimenting (as well as a bit of poking around in the Black Mesa binaries) and discovered that the game crashes on startup while attempting to load the Hazard Course’s changelogs (which are just plain text files) into an insufficiently large buffer in stack memory, causing a write error due to buffer overflow.

I’m not sure why it’s attempting to read our changelogs, since they contain no useful information for the game, but I’ve confirmed that removing the changelogs from the VPK fixes the crash. Regardless, this should be looked into and fixed anyway, since somehow I doubt that reading in large useless text files into buffers that are too small is correct behavior for the game.

However, even with that particular crash out of the way, we still encounter lots of problems with content mounting via workshop. Specifically:

  • The game does not recognize the following custom files/content from a workshop VPK:

[list][*]Character Presets

  • Choreography
  • Particle Effects
  • Intro Credits
  • Captions
  • Response Rules
  • Sounds (at least *.wav files)
  • HUD hints and other localized strings
  • Main menu entries
    [/:m][]The PlayerDied, PlayerHealth, FlashlightOn, FlashlightOff outputs from a logic_playerproxy entity never fire correctly.[/*:m][/list:u]None of these issues (other than the perpetually broken logic_playerproxy entity outputs) are present when simply mounting a VPK in gameinfo.txt.

#3238

This is very useful information, thanks for investigating. Some wacky, unintended behaviours here for sure. I’m passing it on to the brogrammers and will let you know as soon as we learn more.


#3239

Someone fire this man


#3240

done