"HL2.exe has stopped working" when loading 'Surface Tension' maps

#1

Black Mesa crashes with the message “HL2.exe has stopped working” when loading the ‘Surface Tension’ section (see crash file attached). I tried to load the map manually by using the console but I get the same result. In fact I can’t load any of the ‘Surface Tension’ maps (from bm_c2a5a to bm_c2a5e). Any ideas?
hl2_3943_crash_2013_11_15T17_57_12C0.mdmp (95.5 KB)

0 Likes

#2

These maps are massive and ask alot of resource.

PC specs?

Correct me if I’m completely wrong.

0 Likes

#3

I’m playing on an HP G62 Laptop with a Radeon HD 5470 (512MB ). Surely, it’s not meant for gaming but so far Black Mesa ran smoothly on ‘High’. I already tried to lower the settings to minimum but that didn’t help either.

0 Likes

#4

maybe get new drivers for your GPU? you might need to use mobility modder .net to get the latest drivers working with yours

0 Likes

#5

I’m also having the same bug, strange.
Seeing as I played this last year and got way past this part without any crashes, in this second playthrough I can’t seem to get past this part, all my drivers and such are up to date so I don’t believe it’s that.

0 Likes

#6

Also - sorry for doubleposting, but it seems like it crashes by something spawning.
Because once the map loads, it’s fine for atleast 1/2 seconds, I can move my camera around and move just fine in that short amount of time, but then it just freezes and closes (with the error message “HL2 has stopped responding” of course).
It may not be crashing due to something spawning, but it atleast acts that way.

Even though I don’t believe it’s my specs or driver causing the problem (because once again; it worked last year just fine and I just checked my GPU drivers again and they’re up to date), these are my specs:

GPU: GeForce 9500 GT
CPU: Intel® Core™2 Duo CPU E7400 @ 2.80GHz
Memory: 2.00 GB RAM (2.00 GB usable)
Resolution: 1842 x 1036, 60Hz (I’m using a TV as a monitor, that’s why I have an odd resolution)
Operating system: Microsoft Windows 7 Ultimate.

(I also attached the Crash Report aswell for you to check out)
hl2_4104_crash_2013_11_18T21_16_37C0.mdmp (82.9 KB)

0 Likes

#7

Maybe try running blackmesa with the argument -heapsize 1024000 and if that doesn’t work try -heapsize 768000

0 Likes

#8

I’m not sure how exactly I’m supposed to run it (with the argument -heapsize 1024000/768000) but I tried to run it via Steam (right-clicking Black Mesa - Properties - Launch Options and put one in, tested and it didn’t work, tried the other and didn’t work), so either I’m doing it wrong or Black Mesa just doesn’t want me to continue playing :stuck_out_tongue:

0 Likes

#9

There has been a SDK update recently (2.2 GB ) and the Surface Tension maps are accessible now. Looks like I can finally finish the game. :slight_smile:

0 Likes