I can't open up Black Mesa. Help me

I just bought the official Steam version of Black Mesa on my Windows 10 laptop, but I cannot open it up. I tried everything. I tried restarting my computer, but it wouldn’t work. I tried reinstalling it, nothing. I tried verifying the intregity of my files, nope. I tried opening it by going into files and opening the bms, but I got nothing, not even when I ran as administrator. I tried going to the process section of task manager to find hl2.exe, but it isn’t there. I could really use some help.

When you open Steam and click on “Black Mesa” in your library, does the main button say “Install” or does it say “Play”?

If it says “Play” what happens when you click on it?

Play, but I get nothing. Here’s how it goes: I click play. Then I say Yes to the Steam Client Service thing. Next, it performs the first time setup. Then it says running. But then, it just stops and the game won’t play.

I am sorry, I am not sure I can help you. I know this is the official Black Mesa forums, however they usually hang out over at the steam forums as well as discord.

Could you perhaps post your problem there?

Thank you. I will go to the Steam discussions.

Check to see if your machine meets the Minimum System Requirements.