Instances not working correctly in BMS.

Hi all. After attempting to create instances for use in my BMS map, they seem to compile into the game fine but I can’t fire any logic inputs to them. Nothing happens, and I get something like this when attempting it with ent_fire:
[tt]unhandled input: (trigger) -> (wt_trafficlight_greenlight_on), from (player,); target entity not found[/tt]
I’ve checked and double-checked all fixup names are correct with verification from outside sources additionally. I’ve also tried collapsing the instances and giving them the same fixup prefix and they work fine.

Are instances even supported in BMS, broken, or just not implemented? Please let me know. The instance VMF is attached. (1.28 KB)

As far as I know, instances are not supported by BMS. They’re a relatively new feature to source games, and so far it seems that only newer Valve games support them. One of the devs could probably tell you why they don’t have them (or choose not to), but I’m guessing for now you’ll just have to bake your setup directly into the map.

However, if you’re looking for a way to quickly paste pre-made setups into a map, you can always use prefabs. They’re pretty simple to make, and I have had no trouble with them in BMS.

Alright, thanks for clarifying. I was under a false assumption that they did work because basically everything but logic worked.

They are supported (we use them a lot), but logic doesn’t work currently. I believe this is fixed on the Xen branch.