Is there a way to tweak lighting?

It’s been years since I tried BM. With the impending Xen release I decided to hop in and see what the game’s like today, and I was blinded by the light.



These are the examples of what I’m talking about: the top one is a clipboard under a ceiling lamp, the bottom one is the same clipboard in a slightly less illuminated corner. Stuff is just too bright and reflective. I tried to tweak all in-game settings available but none of them changed this. Is that how the entire game is?

When you play the rest of the game what does it look like.

Pretty much the same: objects directly under light sources are excessively bright/illuminated, while looking absolutely fine in darker areas.

That cant be normal. Perhaps post this on the steam forums to see if anyone has a clue.

Have you ever subscribed or installed any mods.

I just installed BM and I never used any mods, nor do I experience such issues with other Source games, like HL2 or episodes.

I posted on BM’s Steam forum and was told that this an HDR related issue. They suggested disabling bloom via setting mat_disable_bloom to 1, which did the trick.


With bloom enabled

With bloom disabled
Is this a known issue? I forgot to mention that I’m on the stable version.

Interesting. Even with bloom off it seems a bit bright. At least it isnt blinding tho.

There are a number of known lighting issues in BM that contribute to this.

  • For a while, some props without normal maps would become very bright for no reason. These were mostly static props, but the issue could be fixed with the command r_meshstaticlighting 0. However, this issue seems to have gone away in post-Interloper versions of the game, replaced by…
  • In maps with skyboxes, some objects will ‘shine’ very brightly at inappropriate times, although again these are usually static props.

I don’t really think this is a bug in the strict sense, though. Black Mesa’s maps are just lit in a very unrealistic way that has a very sharp falloff between light areas and dark areas. Disabling bloom is changing the game away from how it’s ‘meant’ to look, but if it improves your experience by all means more power to you.

You can also tweak the intensity of bloom with this command:

mat_bloom_scalefactor_scalar

I lowered it a bit, it’s set too high by default.

Just thought I should post an update post-Xen patch. Everything works great using the default settings now, visibility is a-ok without tweaks of any kind.