No music on window 8.1

windows

#1

Hello i have no music when i play : i heard the voice of scientist and gunshot but no sound . The console option indicate many error message when a music is suppose to begin .


#2

Please post your system specs and whether you have the Legacy mod or the Steam Game.


#3

I use the steam game , you mean processor , RAM and systme type ?


#4

yes

Also, do you have any mods installed.


#5

processor Intel core i3_3220 CPU @ 3,30GHz 3,30 GHZ : Ram : 4 G0 , Explotation system 64 bits and processor x64

I have just upload the French sub mod


#6

Do you sub to any mods that alter the music, is on the normal gameplay or on a mod?

In the console, type:
snd_restart

and reload your saved game and see if it helps.


#7

Download and install [tt]vcredist_x86.exe[/tt] from this page: Microsoft Visual C++ 2010 Service Pack 1 Redistributable Package MFC Security Update
EDIT: A newer version (10.0.40219.473) is available here: https://download.microsoft.com/download/E/E/0/EE05C9EF-A661-4D9E-BCE2-6961ECDF087F/vcredist_x86.exe


#8

Is that the one that fixes it?
I have been recommending the all in on (AIO) from
https://forums.guru3d.com/threads/new-c-installer-released-hassle-free-uninstaller-reinstaller.393405/
or
http://m.majorgeeks.com/files/details/visual_c_runtime_installer.html

There’s more than a few threads in the steam forum with similar issues.


#9

normal gameplay , no music change mod


#10

Yes, that one should fix it inasmuch as the VC++ 2010 x86 redist is needed by the Ogg Vorbis library which the game uses for decoding the music files. You only need the x86 one, not the x64. The rest of the game uses the VC++ 2013 redist, which has been bundled with the game.

It appears that the AIO installer you linked to has a newer version of the VC++ 2010 redist than the one I linked to. However, I found a direct download link to the same version: https://download.microsoft.com/download/E/E/0/EE05C9EF-A661-4D9E-BCE2-6961ECDF087F/vcredist_x86.exe (via this page).


#11

AWESOME
Thanks for that information.
There is a thread in the steam forums that I am gonna post that in right now.
You da man.


#12

why the game dont download all those file when we install it ?


#13

Because on all the devs machines those microsoft programs were already installed. Same for most anyone who was on Windows 7.
The devs did not realize those dependencies should be included.

Did it fix your problem?


#14

I have download visual C ++ 2013 , i have to download the security patch of 2010 or it is not necesary ?


#15

It is not necessary to install the Microsoft Visual C++ 2013 Redistributable (64-bit) or the Microsoft Visual C++ 2013 Redistributable (32-bit). They get installed automatically when you install the game (the installation files for these are located in the folder …\steamapps\common\Black Mesa_CommonRedist\vcredist\2013).

You only need to install the Microsoft Visual C++ 2010 Redistributable (32-bit).

There are several versions of it available. The latest officially supported version available for download on Microsoft’s website can be found here: The latest supported Visual C++ downloads

Browse down the page, and you’ll find a link to Microsoft Visual C++ 2010 Service Pack 1 Redistributable Package MFC Security Update

It is labeled a security update, but it just means you get a newer version than what was released originally.

However, there’s an even newer version circulating on the web. I don’t know why you can’t find it on Microsoft’s Download Center, but below are direct download links to both the 32-bit and the 64-bit version of the Microsoft Visual C++ 2010 Redistributable:

Microsoft Visual C++ 2010 Redistributable (32-bit)
Microsoft Visual C++ 2010 Redistributable (64-bit)

These links go to Microsoft’s own download servers, and the files are signed by Microsoft, so they should be safe.

You can install both the 32-bit and the 64-bit version for good measure, but you’ll only need the 32-bit version (vcredist_x86.exe) to fix the problem with no music in Black Mesa.


#16

For the 32 instead to 32 bit i have X86


#17

I have download and no change


#18

Yes, that’s the 32-bit version. The setup file is named [tt]vcredist_x86.exe[/tt]

I assume you installed it as well? if not, double click on it to run the installer.

Verify that you have the necessary Visual C++ Redistributables installed. In Windows, open Programs and Features (open Control Panel, then select Programs -> Programs and Features (Panneau de configuration, Programmes > Programmes et fonctionnalités)). You should have these installed:

[attach=5858,none,773][/attach]

If you find these in the list of installed programs, then I would try to unsubscribe and uninstall the French subtitle mod you installed, and then verify the integrity of the game’s files. Start a new game from the beginning instead of loading a saved game to make sure it’s not a corrupted save. Music should start to play shortly before the tram ride starts.

Other things to try:

  • Restart your computer.
  • Delete all the *.sound.cache files in the …\steamapps\common\Black Mesa\bms, …\steamapps\common\Black Mesa\bms\sound, …\steamapps\common\Black Mesa\hl2 and …\steamapps\common\Black Mesa\hl2\sound folders.
  • Type snd_restart in the console. Alternatively, add +snd_restart to the game’s launch options.
  • Disable Steam Cloud synchronization for Black Mesa (in Steam, open the game’s properties, go to Updates, under Steam Cloud, clear the checkbox next to “Enable Steam Cloud synchronization for Black Mesa”.
  • Update your audio drivers.
  • As a last resort, make a clean reinstall of Black Mesa: Make sure you have unsubscribed from any mods in the Workshop, then uninstall Black Mesa, then make sure the steamapps\common\Black Mesa folder and the steamapps\workshop\content\362890 folder are empty or deleted, or delete them if they are not. Finally, reinstall Black Mesa.


#19

I have check all files and they are all ok , error console : Faille to create … MP3


#20

Restart your computer, launch Black Mesa and type snd_restart in the console.