Ship Black Mesa with libtcmalloc_minimal on Linux?


#1

I run Black Mesa on Linux using Flatpak’s distribution of Steam. A few days ago, the game worked fine. However, as of April 29th, the game will not launch and from the terminal I get the error

/home/edwargix/.var/app/com.valvesoftware.Steam/data/Steam/steamapps/common/Black Mesa/bms_linux: error while loading shared libraries: libtcmalloc_minimal.so.4: cannot open shared object file: No such file or directory

I’ve seen this error before; Portal 2 had this issue a while back, and solved it by shipping libtcmalloc_minimal.so with the game. Would it be possible for Black Mesa to do the same?

Thanks

BTW, since Flatpak maintains its own libraries and sandboxes its applications, I unfortuneately can’t simply install libtcmalloc on my distro


#2

Thank you for the post! We are currently aware of this problem and will be solving it in a upcoming hotfix.


#3

Bump. I just bought the game, and it won’t launch; same error. Looking forward to the hotfix! :slight_smile:


#4

I ended up manually installing this library, and the game started after doing so.

No sound, many black/missing textures, numerous lighting issues, enabling antialiasing drops performance drastically and introduces graphical glitches.

Screenshots:

https://i.imgur.com/23ZmjVk.jpg

https://i.imgur.com/hiFbXWQ.jpg

https://i.imgur.com/78AIQJy.jpg

I have requested a refund. I might buy this game again later if these issues are fixed, but I consider the Linux version unplayable in current form.