(Solved) Weird text bug in settings screen


#1

I have a freshly installed game and i see this weird text distortion or like some parts of the text is halved. I had this occur on my other pc too.
Specs: Windows 7 64bit, GTX 1080, I7-7700K and 32GB of RAM
If anyone could help resolve this I would be very grateful.

Even when i write in the console the letters are bugged. The letter d is showed as c.


#2

Try changing your aspect ratio


#3

Changing my aspect ratio did not change anything. The text was still halved, even if i changed my resolution.


#4

I noticed that the letter d is missing its first part and is now the letter c.


#5

Try running the game in fullscreen instead of borderless fullscreen to see if that changes anything.


#6

That did not change anything. Im adding a picture of console maybe that helps.


#7

The console font and the small font on the advanced video settings dialog look crisp and fine, so it’s not FXAA.

I’m pretty sure I’ve seen this issue before, but I can’t seem to remember what was causing it and/or what the solution was. It could be a display scaling issue. Check the display scaling settings in Windows and in the NVIDIA Control Panel.


#8

I tried “disable display scaling on high DPI settings” but that did not work. On Nvidia panel i tried override the scaling mode set by games and programs: first with aspect ratio selected then i tried full screen and then i tried no scaling but that did not work either. When you said windows display scaling settings where exactly should i look.


#9

Right click on the desktop and click Display settings. Under Scale and layout -> Change the size of text, apps, and other items, make sure it’s set to 100%.


#10

It is 100% . I did not have scale and layout option. But i think this is what you meant?


#11

Perhaps you have corrupted fonts.
This is what Microsoft shows for Windows 7.
https://answers.microsoft.com/en-us/windows/forum/windows_7-desktop/how-do-i-fix-corrupted-font-files-in-windows-7/7860617d-e4a8-4792-a84b-b83f4bfd81b4

**Fix corrupted font files in Windows 7

Method 1:
You may restore the fonts to default and check whether the issue is resolved. Follow the steps mentioned.

a. Open Fonts by clicking the Start button, clicking Control Panel, clicking Appearance and Personalization, and then clicking Fonts.

b. In the left pane, click Font settings.

c. Click Restore default font settings.

Note: If you cannot see Appearance and Personalization in control panel then, change the ‘view by’ to ‘category’

You may refer the link for help:
http://windows.microsoft.com/en-US/windows7/Fonts-frequently-asked-questions

Method 2:
You may run SFC (System File Checker) scan. This scans for any integrity violation. If it finds any corrupted system file, it tries to replace the files.
If the System File Checker tool cannot repair a file, follow the steps to manually repair the file from the article.
How to use the System File Checker tool to troubleshoot missing or corrupted system files on Windows Vista or on Windows 7

http://support.microsoft.com/kb/929833

You may also refer the links for more help:
Change your font settings
http://windows.microsoft.com/en-US/windows7/Change-your-font-settings
Install or delete fonts
http://windows.microsoft.com/en-us/windows7/Install-or-delete-fonts`


#12

Yeah, sorry, my instructions were for Windows 10. I didn’t notice that you were on Windows 7.

I don’t know if this might help, but from your Control Panel screenshot it looks like ClearType might be disabled, because of the pixelated text in the Window. Go back to the Display settings in Control Panel and click Adjust ClearType text. That should bring up the ClearType Text Tuner wizard. Make sure ClearType is enabled and click through the wizard. Then try running the game again.


#13

Yeah that helped thanks. Keep up the good job :smile:


#14

I tried The SFC scan and it stopped working at 8% and said that it found corrupt files and could not repair them. Then i did the log file to .txt conversion and i could not really understand what was corrupted in there.
Though cleartype text tuner fixed it.

If you could maybe make out what it says that it could not repair.

https://drive.google.com/file/d/1uOSuMtGZHTehS6KcM3TDqXwDxnQFJNjK/view?usp=sharing


#15

It looks like it tried to verify a component in

C:\Windows\WinSxS\amd64_microsoft-windows-comctl32-v5.resources_31bf3856ad364e35_6.1.7600.16385_hu-hu_a8b2089d86ece2f0

…but it couldn’t because the folder didn’t exist.

You could try running the System Update Readiness tool to see if that fixes it. It’s available here: https://support.microsoft.com/help/947821

After you’ve installed and run it (it might take a while to finish), open the following log file:

C:\Windows\Logs\CBS\CheckSUR.log

This log file will list errors the tool found but couldn’t fix. For more information on how to fix errors found in this log, see: https://support.microsoft.com/help/2700601

You can also find some more information on this tool here:

After you’ve run the System Update Readiness tool, restart your computer. If there were no errors in the CheckSUR.log, you can try the sfc /scannow again and see if it completes without errors.