The Elder Scrolls: Skyrim


#221

Actually, if they made the houses modular, I don’t think it would be too hard to make them dynamically destructible, at least to a limited extent.

Obviously this would only work if the interiors of buildings are no longer separate cells, but it’s been done before, like in the Red Faction games.


#222

Well, yes, not actually impossible. I should have rephrased that, it was originally part of a longer sentence.

Still, it would probably be rather hard, and it would probably be even harder to make it look good.

Also, I was mostly thinking about dungeons, because, well, I’m playing arena at the moment and passwall is a huge help there, and there it would probably be a lot harder to do, because while a piece of wall placed on top of a ground mesh would be easy to remove, blasting away a chunk of the cave-wall without anything on the other side, you’d have to add a new ground tile, new walls on all sides, and all that.
This would probably be possible if you created tiny little rooms everywhere that could just alter form slightly and connect, but it would be far too much work if the player could do it pretty much everywhere they wanted, especially considering the more dynamic layouts of dungeons, working on multiple levels, with stairs and chasms everywhichway.


#223

It would work much better with procedurally generated or extremely modular dungeons, both of which would most likely be bland and repetitive compared to the highly varied dungeons in Skyrim.

Breaking down walls would be nice, but I’d much prefer my dungeons to be pretty and unique.


#224

Just the point I was making.


#225

OK, so I’ve run into a very nasty glitch.

I started the civil war on one of my characters and got up to the battle for Whiterun. I went to talk to Legate Cipius, but I ran into this glitch where guards won’t try to arrest me for my bounty and just say “Wait, I know you…” when I press E on them. Since Cipius is technically a guard, he fell victim to this too, rendering me unable to talk to him and thus to progress through the quest.

According to the wiki, this is a known bug, and you can fix it by just attacking a guard. So I hit one of the guards and nothing happened until I killed him, at which point another guard finally tried to arrest me.

So I used my thane get-out-of-jail-free card to eliminate the bounty, but the guard went right back to attacking me. According to the wiki, this is also known, and you can fix it by simply fast-traveling somewhere else and back. This worked, for the guards, but when I went back into Dragonsreach the Jarl, his housecarl, and his steward were all hostile to me. Yielding to them didn’t seem to work and I got killed pretty quickly every time I went inside.

The only save I have before this point is one way back before I even started the civil war quests. I’m going to try to fix it using console commands when I get home, but if that doesn’t work, does anyone know what might? I have no idea what’s causing this.

Edit: Actually I might just be able to fix this by fast-traveling away and back and just making sure that 48 hours have passed.


#226

Also, first batch of Dragonborn screenshots:

http://imgur.com/a/6zIM9#0

:awesome:


#227

Looks awwweeeeesome.


#228

I love that they’re finally going back to a really different, unique environment; no more icy mountains and rocks.

Who knows, maybe we’ll get to visit Elsweyr someday. None of the recent games have been set in either a desert or a jungle.


#229

I like how the Nords are actually wearing WARM CLOTHES! finally


#230

God damn, this is getting me actually interested in Skyrim again.


#231

Ahhh balls. I can’t summon Durnehviir.

After beating him in the Boneyard I left and found him waiting for me outside. So I ran away from him. And now he’s gone completely! I didn’t realise he would start a quest to learn a new shout.


#232

You think that’s bad?

On my old character, I killed [[color=’#151515’]Paarthurnax] because I didn’t realize that I actually had a choice. :’(

Edit: Also, I finally got the master-level destruction spells today:

:awesome:


#233

Now you have UNLIMITED POWWWEEEERRRRRR

http://www.youtube.com/watch?v=ReXkOEK9JfQ


#234

So, Dragonborn’s out for the Xbox right now. Anyone here been able to check it out yet?


#235

No PC until 2013 huh?


#236

Unfortunately not. I’m hardly complaining, though, since I’m broke anyway.


#237

And not out on the PS3 until…NEVER


#238

Actually, it’s coming out on the PS3 the same time as the PC version.


#239

They said the same thing when Dawnguard was announced i think


#240

But this time, they resolved the memory limitations by making Solstheim a completely separate world map.