$treesway


#1

In the April update, is there any particular reason why I’m not able to add $treesway to some existing models, like models/props_foliage/mall_tree_medium01.mdl? I should be able to locally have a VMT of the same name that adds those settings, right? As a local test, for that tree specifically, I tried adding VMT in bms/materials/models/prop_foliage/mall_trees_branches02.vmt. The vmt looks like this:

[code]VertexlitGeneric
{
$baseTexture “models\props_foliage\Mall_trees_branches02”

$AlphaTest 1
$AlphaTestReference “.35”
$nocull 1
$model 1
$FlashlightNoLambert 1
“%keywords” l4d2

$treeSway 2
$treeSwayHeight 512
$treeSwayStartHeight “0.5”
$treeSwayRadius “256”
$treeSwayStartRadius “1.0”
$treeSwaySpeed “0.050505”
$treeSwayStrength “0.020205”
$treeSwayScrumbleSpeed 3
$treeSwayScrumbleStrength “0.101”
$treeSwayScrumbleFrequency 4
$treeSwayFalloffExp 5
$treeSwayScrumbleFalloffExp 7
$treeSwaySpeedHighWindMultiplier 6
$treeSwaySpeedLerpStart “2.0”
$treeSwaySpeedLerpEnd “6.0”
}[/code]But the changes don’t show up in-game. However, if I change aspects of this VMT (like disabling AlphaTest), the changes do show up in Hammer. So, I’m confused. I also tried this using leaves.vmt, which is used by bush01_dead.

I also tried doing this in bms/custom/(nameofmap)/materials/models/prop_foliage/mall_trees_branches02.vmt. Didn’t work. There is no motion at all.

As a point of reference, I have a bushsm.mdl model in my test map which is blowing around as expected, as it does in the main game.

So, what’s wrong? Am I putting these in the wrong place?