Water is almost invisible


#1

Hi there,

In my Black Mesa game, all the regular water is almost completely transparent (looking at it from the outside). The water sounds and swimming animation is there. Strangely I can see the radioactive fluids just fine.

Screenshots:

  1. http://pbrd.co/1tqgH79
  2. http://pbrd.co/1tqjtJu
  3. http://pbrd.co/1tqjygo
  4. http://pbrd.co/1tqjDRh (when I am swimming, all looks OK from below the surface)
  5. http://pbrd.co/1tqjMEj
  6. http://pbrd.co/1tqjSvo

Remarks:

  1. The screenshots taken are from the dam in Surface Tension, but the issue affects all water throughout the game! Just to clarify… :wink: )
  2. The issue is not related to the available command to make water gone! I tried that one already without any effect: mat_drawwater 1

I am a bit confused, as I didn’t have this issue with the first version of BMS, but since updating to the most recent version. Additionally I installed the “On the rails uncut” extension so as the “Xen” maps. Might I have messed something up by installing those?

Does anybody have a clue how I might investigate the root cause of this issue or even how to fix it (probably a missing/wrong file or something)?

Thanks for any help and ideas :slight_smile:


#2

I tried reattaching the screenshots to this reply:
bm_c2a5a-Surface_Tension-Dam-WaterIssue-Example1.jpg
bm_c2a5a-Surface_Tension-Dam-WaterIssue-Example2.jpg
bm_c2a5a-Surface_Tension-Dam-WaterIssue-Example3.jpg
bm_c2a5a-Surface_Tension-Dam-WaterIssue-Example5.jpg
bm_c2a5b-Surface_Tension-Dam-WaterIssue-Example1.jpg


#3

You did what? There’s only one version of Black Mesa out right now. :expressionless:
I don’t know what you did, but I’d start looking there first. I’d pin that as the culprit.

Those are fan mods, not official extensions. While it’s possible they could have broken something if installed incorrectly, they shouldn’t have caused any problems if they weren’t.

I’d start with a fresh install of Black Mesa and see if the problem persists.


#4

Well probably I am wrong, but I thought I had it reinstalled like a year ago or so… used the official torrent of course from ModDB.

I thought it was something like a 1.0.1 version (post 1.0 release with minor fixes). But I could be wrong about that - sorry for the confusion.

Anyhow, I think you are right: a fresh install might be the best solution. At least to verify, if I experience the same issue with water.


#5

Try installing “Source SDK Base 2013 Single Player” That fixed it for me.


#6

Bad news: a fresh install didn’t help. Issue with transparent water is showing up again in a plain fresh BMS setup.

Thanks for the hint. You only installed SDK 2013 via Steam > Tools and then BMS showed the water correctly? Or did you have to rebuild/connect a part of BMS with the SDK 2013 somehow? Thanks for clarification


#7

Try typing buildcubemaps into the console? Maybe something went funky with the cubemaps. Might help, might not.


#8

I did, but didn’t help.


#9

Verify the Source SDK Base 2007 Cache?


#10

Maybe something is messed up in your GPU driver settings, you might need to reset settings like LOD Texture quality or SSAO.


#11

Tried the command “mat_dxlevel” out as described in /r/BMS here.

But this is not the issue - as the following screenshots proof.

A ) mat_dxlevel 95 (default):

B ) mat_dxlevel 90 (lower):

I will no try to go with @sersoft’s feedback and try fixing the GPU settings…