Weird light squares in skybox light


So, for some reason, my skybox lighting is all screwed up and there are random squares of light everywhere. I can’t figure out how to get rid of 'em. Any help?

If it matters, my light_environment settings are:
Brightness: 217 226 234 0
Ambience: 122 140 169 20



Are you compiling w/ fast VRAD?



Nope, though I am using -low, if that could be an issue.
Also, here’s a better picture to show the problem. I changed the skybox and environment lights, and tried making the geometry more simple, but it’s still there.



What engine branch are you on? I know having named lights or lights with an appearance value other than normal can cause such issues on the CS:GO branch.



I’m actually using the hammer found in Black Mesa’s bin.
As well, the skybox is currently the only source of light in the whole map, which consists of that room and nothing else.
It’s really strange. The map has brushes, a light_environment, an env_sun and an info_player_start, but no other entities. That last screenshot is even using a skybox with the entities copied straight from one of the official maps.



Use the texture tool and check what lightmap resoultion you have on the blocks, use 4-8 for nice shadows, but it’ll increase compile time a LOT.
It looks like there are some models at the windows? If the above doesn’t help, try hiding them to see if anything happens.

Also post the compile log.



I deliberately lowered the lightmap to 4, when I noticed the light was splotchy. Lowering the resolution revealed the squares in the pictures.
And there are no models at the windows, nor in the map at all currently. This issue popped up very early in development.

Ah, character limits. I can’t put the compile log directly in the post. Here’s a pastebin.



Nice abstract art.



I’ll set the skybox light to be a strange color, make it cast onto a white texture, screenshot it, and sell it for $7 grand!



If you ever find out what caused this please post it. I think it would be a lovely design to add to a map, even for a single room.



You got it man, but I gotta actually fix it first! It’s still happening.



Is it happening in all areas across the map?
Maybe try introducing a light ent and see if that does anything. I think the compile tools have a fit if you don’t have at least one.



Like I said, right now the map is just that one room. But I carved a larger hole into one wall, and added a light entity. The issue is still there, but it seems to be less noticeable wherever the sunlight is more direct. I’d say it might be an issue with VRAD not knowing how to deal with shadows in this situation, but I’ve seen maps with windows before with perfectly fine lighting.

EDIT: Amusingly, I get almost the exact results I want by getting rid of my light_environment, and just using light_spots. Though I’d much rather just fix my skybox issues, so that I don’t have to spend hours perfecting my artificial sunlight technique.



If your map is currently just one room, just maybe you could post VMF and see if other mappers could look into the file to figure out the problem? If it certainly does not happen in any other map, it must be something in the map file that is causing it. Did you try rebuilding the geometry from the scratch too see if it resulted in same thing by any chance?



I did try making a different map, and no matter what, the squares seem to appear when I try to make some form of window in a room.
Here’s the VMF though. Maybe, if it doesn’t happen to you, then I can narrow down that there’s some kind of corruption in Hammer that isn’t being detected by game file verification. Hell, I even tried deleting every file related to VRAD and had Steam reinstall them. No change.
I also tried changing compiling options. Fast, HRD only, LDR only, absolutely no change. It’s getting frustrating.

On a side note, sorry if the file hosting site seems a little shady. I couldn’t attach it on the forum because of stupid file extension restrictions, and Mediafire seems to be having server issues or something right now. Couldn’t upload it.



Just ran a HDR compile with CompilePal (not Hammer standard compiler). And I got this:

In conclusion, it happens but very faintly, but still noticable. Now I’m starting to get really curious why this happens…



Well it definitely looks much better!
Maybe later I’ll try the same map in a different game’s Hammer. Though I’d like to use Black Mesa because it’s the best branch of Source I own that doesn’t need me to place 2 teams worth of spawns.



Ok, tested a lot of different things, none solved it…
The hl2 prison part with the antlion guard, also uses the skybox to create lighting from windows, so it should work for this map too.

What I guess you can do is use the skybox for the windows, then add some lightings in the room to create their own shadows.

and minor sillyness: always use lowercase in mapnames, source had a bug a while ago where files with highcase in names didn’t download. + it looks better.



Oy, that’s annoying. Seems like whenever I wanna make something, there’s a problem I can’t fix that ruins all of my inspiration. Thanks, though.
If you couldn’t guess, I was actually going for a Nova Prospekt theme. Hearing about Prospekt, that fanmade Opposing Force sequel, being a massive flop made me want to try my hand at making something a bit more Valve-looking. Something interesting to show off on the Show Off Your Everything thread, y’know?

And to be honest, I don’t actually release anything (no way, not until I get wayyy better at mapping), so I don’t think the capitalization should matter much. But I’ll keep that in mind when I make something actually worth releasing, thanks!



Major update! I’ve pinpointed to issue to be directly related to the “Ambient” light setting in the light_environment.

With Ambient set to how it is in official Black Mesa maps:

With Ambient set to 0 0 0 0:

If everyone else agrees that the second screenshot looks normal, then I’d call this problem solved!