What Game Did You Play Today?


#4481

I played The Witch’s House after seeing the Best Friends play a bit of it on their annual halloween Shitstorm special. It’s a free RPG Maker horror-themed puzzle adventure. Short; I beat it in under an hour and a half. For the most part, it doesn’t suffer from the, “Now guess what I was thinking when I designed this. Love, the developer,” obtuseness that some adventure games can. Good art, decent story, did an effective job of both scaring me and making me laugh at certain points. A very polished little freeware game.


#4482

I tend to gravitate to the simple games. Some of my favs are:

Osmos
youtube.com/watch?v=jrzhlTn1_ds

Dots & Co
youtube.com/watch?v=0uKsgeLPmEY

Brain it on
youtube.com/watch?v=DLSxpePtxss


#4483

Bought, played, and beat Evil Within 2. I highly recommend it if you loved Silent Hill/Resident Evil 4. It looks good, with only a few animation glitches. My only complaint is that

where the fuck did Ruvik go?? I was disappointed when he never showed up really, unless the end is alluding to him but who knows really.

Othwrwise, I really enjoyed the game. Beat it in about 14 hours, so it’s got some heft to it. You also don’t run like an obese, 60 year old chain smoker with bad knees.


#4484

I’ve decided to give Star Citizen a try again. A game that I have wanted since the space sims died, I played all the Wing Commanders, my heart was broken when I found out there wouldn’t be a FreeSpace 3. So I’ve had high hopes for Star Citizen, but every time I have tried it, its been seriously buggy. It seems to be a bit more stable now, so I’m hoping this is something I can get lost, we’ll see… Loved all of Chris Roberts’ previous games


#4485

Fired up Skullgirls, played some tutorials for ~15 minutes. This game is intimidating as hell.


#4486

war thunder mostly because things like the image bellow, give me a game of skill and I will find a way to wipe the floor… except for card games. fuck card games.


#4487

Oh boy! New Sonic game!

Oh boy. New Sonic.

Oh boy.

Oh.

It’s alright. Plot’s a fuckin mess though.


#4488

More Like “What gane would you like to play today?” for me:
I found a technically working DVD copy of Resident Evil 4 just lying on the street in front of my house. Took it home to see if it’s working. It installs without any problems, but as soon as i’d like to fire it up, it crashes. i will look for a solution as amsoos as i got the time. Such an awesome game!


#4489

Started up Bioshock 2: Remastered. I never actually finished 2 so I figured I’ll just start it up again using the newer version. I’ve always hated getting back into games after long pauses.

Still need to finish Dead Space 3. That’s one where I don’t care to re-start it. I’ll just continue where I left of.


#4490

I’ve been playing a lot of Binding of Isaac: Afterbirth+.

I started to tire of it a bit, so I pulled out Spelunky, which I got in the Halloween sale for < $1.00. This is probably a good game, but I absolutely hate its style. The art, music, sounds effects… all of them just grate on me.

So I played some Dead Cells, which is an early access title that I bought a bit of a while back. It’s deeper and more enjoyable than I originally gave it credit for.


#4491

“How I Got Hacked”


#4492

no need for hacking, my friend. the copy came with a CD case and a cover inlet, which conviniently provided a workind CD-key. the problem seems to be windows 10 related. the game was released in 2005 after all.


#4493

These scams keep getting more and more elaborate!


#4494

Did you try setting the compatibility mode?,
On a different note, I reinstalled doom again, wow, seems faster than it did at release, what an amazing looking game, I have to say easily the best optimized game I have ever played, I get a constant 144+ fps at 2k resolution everything maxed. I guess i’ll have to break down and get the new Wolfenstein, has anyone played it?


#4495

I tried out The Evil Within, which I got in the sale.

This is an absolutely garbage console port. Since it’s a shooter, I tried to play it with my keyboard and mouse, but you can’t bind the thumb mouse buttons or the scroll wheel, and scrolling in in-game notes is broken! All the notes are cut off, and there’s no way to scroll down and read them with the mouse and keyboard, so you miss huge chunks of the story. The menu is awful, with horrible floaty mouse acceleration, and in the keybinding screen, once you’ve selected a function to bind, there’s no way to back out: any keypress or mouse click is registered as an attempt to bind the function. But, you have to click in the list of functions in order to focus it so you can scroll down to see all of the functions… which selects whatever function you clicked on, and forces you to bind it. You can’t unbind the keys, either, because hitting Backspace or Delete tries to bind that key… so I ended up with multiple keys bound to every function as I desperately tried to navigate this shitty menu. Also, this game commits the cardinal sin of displaying a popup when you try to bind a key that’s already bound, and asking you to confirm the rebind… Every. Single. Time.

So I picked up the controller, since the game was forcing me to, and there’s no option to invert the camera X-axis. You can invert the Y, but not the X.

How do you even fuck up this badly? Refunding this POS. Consoles are poison.


#4496

If it’s any consolation, you’re probably not missing much.


#4497

I played (and am still playing) Deus Ex, got it on sale for 98 cents.
I don’t understand why I haven’t picked this game up earlier, it’s a really great game. Despite me taking two hours to finish a certain mission it’s in a good way.


#4498

In the future check out https://pcgamingwiki.com/wiki/The_Evil_Within for gaming issues, it has saved my but a couple of times.
Notable console commands include:
m_smooth 0 - Disables mouse acceleration


#4499

I concur. PCGamingwiki has helped me with a bunch of games.

Sucks to have to do it sometimes but I’d rather look up a fix and do it to play a game I want/like. Currently trying to find a fix for Bioshock 2: Remastered sound issues.


#4500

I spent the long weekend playing Axiom Verge. Pretty good metroidvania. Very, very Super Metroid.